ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ulrike M (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (IVY-1467) Resolving results in weird working@[localhostname] revisions
Date Fri, 25 Apr 2014 14:15:15 GMT

    [ https://issues.apache.org/jira/browse/IVY-1467?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13981037#comment-13981037
] 

Ulrike M edited comment on IVY-1467 at 4/25/14 2:14 PM:
--------------------------------------------------------

running target "ivy.resolve.compile" will work fine, but target "ivy.resolve.runTest" will
fail with the message described earlier.
IMPORTANT: the failure only happens if the target "ivy.resolve.compile" is run first, followed
by  "ivy.resolve.runTest".
If I clean the local ivy cache, and run "ivy.resolve.runTest", no such error occurs (and I
may run that target or the compile target as many times as I want afterwards). 


was (Author: ulrikem):
running target "ivy.resolve.compile" will work fine, but target "ivy.resolve.runTest" will
fail with the message described earlier.

> Resolving results in weird working@[localhostname] revisions
> ------------------------------------------------------------
>
>                 Key: IVY-1467
>                 URL: https://issues.apache.org/jira/browse/IVY-1467
>             Project: Ivy
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.4.0-RC1
>            Reporter: Ulrike M
>         Attachments: ivy.log, ivy.zip
>
>
> I wanted to give 2.4.0-RC1 a try and ran into this issue. See the log for details.
> I stripped down the case to the bare minimum of what causes the error. If i specify the
following dependencies, resolving conf='
> runtime' will fail with "unresolved dependencies":
> <dependency org="org.slf4j" name="slf4j-api" rev="1.7.7" conf="compile->default"
/>
>     <dependency org="org.slf4j" name="slf4j-log4j12" rev="1.7.7" conf="runtime->default"
/>
> (...)
> :: log4j#log4j;working@PIT11: not found
> (...)
> we are separating compile-time dependencies (slf4j-api) from runtime dependencies (slf4j-log4j12);
this must be specified as two dependencies (as far as I know).
> The funny thing is that if I alter the version of slf4j-api to "1.7.6", clear the ivy
cache and resolve again, it will work smoothly. Version 1.7.6 of slf4j-api will simply get
evicted (as expected).



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message