ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles Gaillard (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IVY-1453) IvyArtifactReport fails to report artifacts when extra attributes are used
Date Wed, 04 Dec 2013 11:50:35 GMT

    [ https://issues.apache.org/jira/browse/IVY-1453?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13838834#comment-13838834
] 

Gilles Gaillard commented on IVY-1453:
--------------------------------------

The report does not contain namespace information about the extra attributes
(it uses an 'extra-' prefix on attributes) and moduleRevToArtifactsMap comes
from the parsed resolve report.
 
ModuleRevisionId.equals uses the getQualifiedExtraAttributes that are correctly 
filled in the dependencies array.

The attached workaround this issue.
A real fix would provide namespace information in the resolve report.


> IvyArtifactReport fails to report artifacts when extra attributes are used
> --------------------------------------------------------------------------
>
>                 Key: IVY-1453
>                 URL: https://issues.apache.org/jira/browse/IVY-1453
>             Project: Ivy
>          Issue Type: Bug
>          Components: Ant
>    Affects Versions: 2.3.0
>            Reporter: Gilles Gaillard
>         Attachments: artifact-report_workaround.patch
>
>
> IvyArtifactReport fails to report artifacts when extra attributes are used. For example
with an ivy-module having dependency:
> {noformat}
>   <dependencies>
>     <dependency org="x"
>                 name="native"
>                 rev="1.0.0"
>                 x:color="blue"/>
>    </dependencies>
> {noformat}
> the generated report doesn't show artifacts.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message