ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 45530] ANT incorrectly copies env.variables with non-latin text
Date Sun, 28 Apr 2013 20:10:51 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=45530

Antoine Levy-Lambert <antoine@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|---                         |INVALID

--- Comment #4 from Antoine Levy-Lambert <antoine@apache.org> ---
using the build file pasted by shoelace_822695 and Java 1.7_0_12-ea on a MAC I
have ran this script called doit.sh:

export RUSSIAN=`echo -e "\xc3\x90\xc3\x92\xc3\x91\xc3\x88"`
echo $RUSSIAN
export ANT_OPTS=-Dfile.encoding=UTF-8
ant  test-linux

the output is here :
bash-3.2$ ./doit.sh
./doit.sh
ÐÒÑÈ
Buildfile: /Users/antoine/dev/asf/45530/build.xml

test-linux:
     [exec] RUSSIAN=ÐÒÑÈ

BUILD SUCCESSFUL

so the russian environment variable seems to round trip correctly. Running with
-Dfile.encoding=UTF-8 (or any encoding in which the particular values can be
represented) is necessary though.

In any case, ant is now using always System.getenv() to get environment
variables, except for openvms [this might need to be revisited ]

Marking this bug as INVALID since there is no actual defect of Ant, at least
not in the Ant 1.9.0 under a Java version >= 1.5

-- 
You are receiving this mail because:
You are the assignee for the bug.
Mime
View raw message