ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée (JIRA) <>
Subject [jira] [Commented] (IVYDE-333) IvyDE does not resolve conflicts between versions of the same package
Date Tue, 26 Mar 2013 20:21:15 GMT


Nicolas Lalevée commented on IVYDE-333:

Are you sure you use the same Ivy configuration in Ant and in IvyDE ?
Have you check you have any warning in the Ivy Console in Eclipse ?
Mayebe you are in the case described there:
> IvyDE does not resolve conflicts between versions of the same package
> ---------------------------------------------------------------------
>                 Key: IVYDE-333
>                 URL:
>             Project: IvyDE
>          Issue Type: Bug
>          Components: workspace resolver
>    Affects Versions: 2.2.0.beta1
>         Environment: Eclipse Juno, Mac OS X
>            Reporter: Sebastiano Vigna
>            Priority: Minor
> When multiple jars for the same artifact are present, Ivy resolves them with the most
recent version, but IvyDE does not. 
> Our LAW project has a dependency on fastutil (v1356767300) that is resolved with fastutil-v1356767300.jar
(a snapshot uploaded to our local server). However, the dependencies of LAW (e.g., DSI Utilities)
have a hardwired dependency on fastutil (fastutil-6.5.0.jar). When we use Ivy from the command
line, it resolves the conflict and we just find fastutil-v1356767300.jar in the jars directory.
However, when we resolve with IvyDE from within Eclipse and look at the list of jars, *both*
versions of fastutil are listed. Depending on which jar appears first in the list we get the
correct class or not.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

View raw message