ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 53921] New: tar task bug when dealing with UTF-8 char isn't solved
Date Sat, 22 Sep 2012 23:55:15 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=53921

          Priority: P2
            Bug ID: 53921
          Assignee: notifications@ant.apache.org
           Summary: tar task bug when dealing with UTF-8 char isn't solved
          Severity: normal
    Classification: Unclassified
          Reporter: aacirino@gmail.com
          Hardware: Macintosh
            Status: NEW
           Version: unspecified
         Component: Core tasks
           Product: Ant

Like reported in https://issues.apache.org/bugzilla/show_bug.cgi?id=36851 I
have had issues with the tar task not being able to use filenames with UTF-8
characters. Consulting the source code I could see that there is an
implementation of the longfile="posix" option I committed, built and installed
version 1.9.0alpha  and was given the following error:

BUILD FAILED
/Users/aacirino/Documents/ws/vtta1.0/build.xml:60: Problem creating TAR:
request to write '110' bytes exceeds size in header of '0' bytes for entry
'./PaxHeaders.X/vtta.woa/Contents/Frameworks/JavaXML.framework/WebServerResources/Java/com/ibm/wsdl/'

when trying to build the install files for my application under Eclipse.

It is also worth mentioning that the current tar task manual states that there
is a posix option for version 1.8.4, what isn't true:

http://ant.apache.org/manual/Tasks/tar.html

To circumvent this issue I changed my build file to use zip instead of tar, but
tar is preferable due to the ability of setting file permissions in the build
file.

-- 
You are receiving this mail because:
You are the assignee for the bug.

Mime
View raw message