ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Frost (JIRA)" <j...@apache.org>
Subject [jira] [Created] (IVY-1360) NPE when using the updatesite resolver
Date Wed, 27 Jun 2012 12:05:44 GMT
Christopher Frost created IVY-1360:
--------------------------------------

             Summary: NPE when using the updatesite resolver
                 Key: IVY-1360
                 URL: https://issues.apache.org/jira/browse/IVY-1360
             Project: Ivy
          Issue Type: Bug
          Components: Core
    Affects Versions: 2.3.0-RC1
         Environment: Command line build with Apache Ant(TM) version 1.8.2 compiled on December
20 2010
            Reporter: Christopher Frost


The error is shown below, nothing else is output from the build. I've been playing around
with the new OSGi support trying to get one of the Eclipse Virgo projects to build with it.
This is a very simple build, no module definitions in the ivysettings file and I'm using the
new updatesite resolver.

<updatesite name="orbit-updatesite" url="http://download.eclipse.org/tools/orbit/downloads/drops/${orbit.repo}/repository"
requirementStrategy="first" />

I can't remember what I did to cause this error, really sorry. Just didn't want to leave an
NPE. Many thanks for the new resolvers though, proper treatment of ambiguity is much appreciated.

[ivy:resolve] 		:: bundle#org.eclipse.virgo.bundlor.ant;1.1.0.M05: java.lang.NullPointerException
at org.apache.ivy.osgi.repo.AbstractOSGiResolver.findIvyFileRef(AbstractOSGiResolver.java:132)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message