ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Hurne (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (IVYDE-303) NullPointerExceptions related to module inheritance repository
Date Mon, 07 May 2012 16:46:49 GMT

     [ https://issues.apache.org/jira/browse/IVYDE-303?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Matt Hurne updated IVYDE-303:
-----------------------------

    Description: 
In both Eclipse 3.6 and 3.7, we are finding IvyDE 2.2.0.beta1 to be unusable due to NullPointerExceptions
occurring when we attempt most IvyDE operations.  For example, the following occurred after
right-clicking on the project and selecting Ivy > Resolve:

{noformat}
eclipse.buildId=M20120208-0800
java.version=1.6.0_21
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.jee.product
Command-line arguments:  -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.jee.product

Error
Mon May 07 12:13:41 EDT 2012
An internal error occurred during: "IvyDE resolve".

java.lang.NullPointerException
	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser$Parser.configureModuleInheritanceRepository(XmlModuleDescriptorParser.java:246)
	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser$Parser.<init>(XmlModuleDescriptorParser.java:233)
	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser.newParser(XmlModuleDescriptorParser.java:142)
	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser.parseDescriptor(XmlModuleDescriptorParser.java:112)
	at org.apache.ivy.plugins.parser.ModuleDescriptorParserRegistry.parseDescriptor(ModuleDescriptorParserRegistry.java:88)
	at org.apache.ivy.plugins.parser.AbstractModuleDescriptorParser.parseDescriptor(AbstractModuleDescriptorParser.java:48)
	at org.apache.ivyde.eclipse.CachedIvy.getModuleDescriptor(CachedIvy.java:368)
	at org.apache.ivyde.eclipse.resolve.IvyResolveJob.run(IvyResolveJob.java:137)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
{noformat}

  was:
In both Eclipse 3.6 and 3.7, we are finding IvyDE 2.2.0.beta1 to be unusable due to NullPointerExceptions
occurring when we attempt most IvyDE operations.  For example, the following occurred after
right-clicking on the project and selecting Ivy > Resolve:

{noformat}
eclipse.buildId=M20120208-0800
java.version=1.6.0_21
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -product org.eclipse.epp.package.jee.product
Command-line arguments:  -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.jee.product

Error
Mon May 07 12:13:41 EDT 2012
An internal error occurred during: "IvyDE resolve".

java.lang.NullPointerException
	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser$Parser.configureModuleInheritanceRepository(XmlModuleDescriptorParser.java:246)
	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser$Parser.<init>(XmlModuleDescriptorParser.java:233)
	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser.newParser(XmlModuleDescriptorParser.java:142)
	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser.parseDescriptor(XmlModuleDescriptorParser.java:112)
	at org.apache.ivy.plugins.parser.ModuleDescriptorParserRegistry.parseDescriptor(ModuleDescriptorParserRegistry.java:88)
	at org.apache.ivy.plugins.parser.AbstractModuleDescriptorParser.parseDescriptor(AbstractModuleDescriptorParser.java:48)
	at org.apache.ivyde.eclipse.CachedIvy.getModuleDescriptor(CachedIvy.java:368)
	at org.apache.ivyde.eclipse.resolve.IvyResolveJob.run(IvyResolveJob.java:137)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
{noformat}

We suspect this may be related to the project's ivy.xml's use of <extends> since the
stack trace above mentions the "module inheritance repository" apparently added in Ivy 2.3.0-rc1.
 For example:

{noformat}
<?xml version="1.0" encoding="UTF-8"?>
<ivy-module version="2.2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="http://ant.apache.org/ivy/schemas/ivy.xsd">
    <info organisation="foo" module="bar" revision="1.0.0" status="integration">
        <extends organisation="foo" module="parent" revision="1.0.0" extendType="all"/>
    </info>
...
</ivy-module>
{noformat}

        Summary: NullPointerExceptions related to module inheritance repository  (was: NullPointerExceptions
possibly related to project ivy.xml's use of <extends>)
    
> NullPointerExceptions related to module inheritance repository
> --------------------------------------------------------------
>
>                 Key: IVYDE-303
>                 URL: https://issues.apache.org/jira/browse/IVYDE-303
>             Project: IvyDE
>          Issue Type: Bug
>    Affects Versions: 2.2.0.beta1
>            Reporter: Matt Hurne
>            Priority: Critical
>
> In both Eclipse 3.6 and 3.7, we are finding IvyDE 2.2.0.beta1 to be unusable due to NullPointerExceptions
occurring when we attempt most IvyDE operations.  For example, the following occurred after
right-clicking on the project and selecting Ivy > Resolve:
> {noformat}
> eclipse.buildId=M20120208-0800
> java.version=1.6.0_21
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
> Framework arguments:  -product org.eclipse.epp.package.jee.product
> Command-line arguments:  -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.jee.product
> Error
> Mon May 07 12:13:41 EDT 2012
> An internal error occurred during: "IvyDE resolve".
> java.lang.NullPointerException
> 	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser$Parser.configureModuleInheritanceRepository(XmlModuleDescriptorParser.java:246)
> 	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser$Parser.<init>(XmlModuleDescriptorParser.java:233)
> 	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser.newParser(XmlModuleDescriptorParser.java:142)
> 	at org.apache.ivy.plugins.parser.xml.XmlModuleDescriptorParser.parseDescriptor(XmlModuleDescriptorParser.java:112)
> 	at org.apache.ivy.plugins.parser.ModuleDescriptorParserRegistry.parseDescriptor(ModuleDescriptorParserRegistry.java:88)
> 	at org.apache.ivy.plugins.parser.AbstractModuleDescriptorParser.parseDescriptor(AbstractModuleDescriptorParser.java:48)
> 	at org.apache.ivyde.eclipse.CachedIvy.getModuleDescriptor(CachedIvy.java:368)
> 	at org.apache.ivyde.eclipse.resolve.IvyResolveJob.run(IvyResolveJob.java:137)
> 	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
> {noformat}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message