ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Haberman (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IVYDE-298) duplicate prefs
Date Tue, 20 Mar 2012 15:21:39 GMT

    [ https://issues.apache.org/jira/browse/IVYDE-298?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13233481#comment-13233481
] 

Stephen Haberman commented on IVYDE-298:
----------------------------------------

Also, besides the list of ivy configurations to use, I don't have any project-level settings
set (I configure it all at the workspace level), so was kind of surprised to see the prefs
file in the first place. I'm not really sure what the setuplist element is for?

Apologies if this is working well and I'm just not understanding something.
                
> duplicate prefs
> ---------------
>
>                 Key: IVYDE-298
>                 URL: https://issues.apache.org/jira/browse/IVYDE-298
>             Project: IvyDE
>          Issue Type: Bug
>    Affects Versions: trunk
>         Environment: Eclipse Version: 3.7.2 Build id: M20120208-0800
> Apache IvyDE	2.2.0.201203150105-hudson-215
>            Reporter: Stephen Haberman
>            Priority: Minor
>
> The .settings/org.apache.ivyde.eclipse.prefs file seems to not be saved correctly. If
I save some settings, I end up with "standaloneretrieve" in the file twice, e.g.:
> {code}
> > cat .settings/org.apache.ivyde.eclipse.prefs
> eclipse.preferences.version=1
> org.apache.ivyde.eclipse.standaloneretrieve=<?xml version\="1.0" encoding\="UTF-8"
standalone\="no"?><setuplist><setup name\="dependencies"><ivysettings loadondemand\="false"
path\=""/><ivyxml path\="ivy.xml"/><retrieve confs\="" pattern\="" sync\="true"
types\=""/></setup></setuplist>
> org.apache.ivyde.eclipse.standlaoneretrieve=<?xml version\="1.0" encoding\="UTF-8"
standalone\="no"?><setuplist/>
> {code}
> ...and actually, something in the IDE must have auto-saved, because now it looks like:
> {code}
> eclipse.preferences.version=1
> org.apache.ivyde.eclipse.standaloneretrieve=<?xml version\="1.0" encoding\="UTF-8"
standalone\="no"?><setuplist/>
> org.apache.ivyde.eclipse.standlaoneretrieve=<?xml version\="1.0" encoding\="UTF-8"
standalone\="no"?><setuplist/>
> {code}
> Maybe the file isn't getting cleared out? Or is this normal?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message