ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée (Commented) (JIRA) <j...@apache.org>
Subject [jira] [Commented] (IVYDE-298) duplicate prefs
Date Tue, 20 Mar 2012 23:05:37 GMT

    [ https://issues.apache.org/jira/browse/IVYDE-298?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13233920#comment-13233920
] 

Nicolas Lalevée commented on IVYDE-298:
---------------------------------------

This project preference file is describing the retrieve setup. With IvyDE 2.1, it was part
of the classpath container. It has moved to this independant preference file so retrieve can
be done on non Java project. So a migration has happend. I remember there was a bug in that
migration, I think it was this issue: IVYDE-259
So I think its OK. Just clean that file. If you see duplicate coming again, reopen this issue.
                
> duplicate prefs
> ---------------
>
>                 Key: IVYDE-298
>                 URL: https://issues.apache.org/jira/browse/IVYDE-298
>             Project: IvyDE
>          Issue Type: Bug
>    Affects Versions: trunk
>         Environment: Eclipse Version: 3.7.2 Build id: M20120208-0800
> Apache IvyDE	2.2.0.201203150105-hudson-215
>            Reporter: Stephen Haberman
>            Priority: Minor
>
> The .settings/org.apache.ivyde.eclipse.prefs file seems to not be saved correctly. If
I save some settings, I end up with "standaloneretrieve" in the file twice, e.g.:
> {code}
> > cat .settings/org.apache.ivyde.eclipse.prefs
> eclipse.preferences.version=1
> org.apache.ivyde.eclipse.standaloneretrieve=<?xml version\="1.0" encoding\="UTF-8"
standalone\="no"?><setuplist><setup name\="dependencies"><ivysettings loadondemand\="false"
path\=""/><ivyxml path\="ivy.xml"/><retrieve confs\="" pattern\="" sync\="true"
types\=""/></setup></setuplist>
> org.apache.ivyde.eclipse.standlaoneretrieve=<?xml version\="1.0" encoding\="UTF-8"
standalone\="no"?><setuplist/>
> {code}
> ...and actually, something in the IDE must have auto-saved, because now it looks like:
> {code}
> eclipse.preferences.version=1
> org.apache.ivyde.eclipse.standaloneretrieve=<?xml version\="1.0" encoding\="UTF-8"
standalone\="no"?><setuplist/>
> org.apache.ivyde.eclipse.standlaoneretrieve=<?xml version\="1.0" encoding\="UTF-8"
standalone\="no"?><setuplist/>
> {code}
> Maybe the file isn't getting cleared out? Or is this normal?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message