ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sven Zethelius (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IVY-1339) LatestCompatibleConflictManager exception on conflict
Date Tue, 20 Mar 2012 20:45:40 GMT

    [ https://issues.apache.org/jira/browse/IVY-1339?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13233726#comment-13233726
] 

Sven Zethelius commented on IVY-1339:
-------------------------------------

Relevant ivy settings file part:
	<latest-strategies>
		<latest-revision name="expedia-latest-revision" />
	</latest-strategies>

	<conflict-managers>
		<compatible-cm name="expedia-conflict-manager" latest="expedia-latest-revision"/>
	</conflict-managers>
	
	<version-matchers usedefault="false">
		<vm-latest />
		<vm-sub-version />
		<vm-version-range />
	</version-matchers>
	
	<settings defaultResolver="${ivy.resolver}"
		defaultLatestStrategy="expedia-latest-revision"
		defaultConflictManager="expedia-conflict-manager"
	/>

                
> LatestCompatibleConflictManager exception on conflict
> -----------------------------------------------------
>
>                 Key: IVY-1339
>                 URL: https://issues.apache.org/jira/browse/IVY-1339
>             Project: Ivy
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.2.0
>         Environment: Windows 7, Ant 1.8.1, Ivy 2.2.1.alpha_20120313100444
>            Reporter: Sven Zethelius
>         Attachments: ivy.txt
>
>
> This is a followup bug to IVY-1233.  With IVY-1233 fixed in the trunk, the conflict manager
no longer infinite loops, but on an unresolved conflict, its not erroring, instead an exception
is occurred.
> Repro:
> A (being built) Depends on B pVer.main.+, C \[1.0,2.0\[, D \[1.5,1.7\[
> B pVer.main.0.0 Depends on D \[1.6.1,2.0\[
> B 1.0.0 Depends on D \[1.6.1,2.0\[
> B 1.1.0 Depends on D \[1.6.1,2.0\[
> C 1.0.0 Depends on B \[1.0,2.0\[, D \[1.6.0,1.7\[
> C 1.1.0 Depends on B \[1.1,2.0\[, D \[1.6.0,1.7\[
> D no Dependencies
> The dependency on B is not resolvable since A and C don't agree on revision ranges.
> Expected:
> Error stating the module(s) that could not be resolved.
> Actual:
> Exception complaining about unrelated module.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message