ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "GK Ephorus (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IVYDE-290) Deployment to Tomcat fails when IvyDE is configured to use "Resolve dependencies in workspace" and referred projects are indeed in your workspace
Date Mon, 23 Jan 2012 09:52:39 GMT

    [ https://issues.apache.org/jira/browse/IVYDE-290?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13190960#comment-13190960
] 

GK Ephorus commented on IVYDE-290:
----------------------------------

This might be related to IVYDE-227
                
> Deployment to Tomcat fails when IvyDE is configured to use "Resolve dependencies in workspace"
and referred projects are indeed in your workspace
> -------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: IVYDE-290
>                 URL: https://issues.apache.org/jira/browse/IVYDE-290
>             Project: IvyDE
>          Issue Type: Bug
>          Components: workspace resolver
>    Affects Versions: trunk
>         Environment: Version: Indigo Service Release 1
> Build id: 20110916-0149
> Plugins (AO):
>   Apache Ivy	2.2.1.alpha_20111113200050	org.apache.ivy.feature.feature.group	Apache Software
Foundation
>   Apache Ivy Ant Tasks	2.2.1.alpha_20111113200050	org.apache.ivy.eclipse.ant.feature.feature.group
Apache Software Foundation
>   Apache IvyDE	2.2.0.201111080039-hudson-200	org.apache.ivyde.feature.feature.group	Apache
Software Foundation
>   Apache IvyDE Resolve Visualizer	2.2.0.201111080039-hudson-200	org.apache.ivyde.eclipse.resolvevisualizer.feature.feature.group
Apache Software Foundation
>            Reporter: GK Ephorus
>              Labels: Assembly, Deployment, deploy, tomcat
>
> When I configure Eclipse to deploy a certain scope of ivy(eg. runtime) to Tomcat (via
Deployment Assembly in Eclipse 3.7) I get nasty NPEs and the document-root is not available
(org.apache.catalina.core.StandardContext resourcesStart
> SEVERE: Error starting static Resources java.lang.IllegalArgumentException: Document
base ..../my-workspace/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/my-context
does not exist or is not a readable directory)
> When I close all projects and only re-open the project that I want to deploy to a Eclipse-managed-Tomcat,
I get no errors during deploy & "Run on server".

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message