ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Gan (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (IVY-1334) Ivy buildnumber task use wrong URL to access Artifactory repository
Date Tue, 24 Jan 2012 01:27:40 GMT

     [ https://issues.apache.org/jira/browse/IVY-1334?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

James Gan updated IVY-1334:
---------------------------

    Description: 
I run "ant publish -v" and get the error message.

[ivy:buildnumber] CLIENT ERROR: Not Found url=http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
[ivy:buildnumber] problem while listing resources in http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
with pubRep:
[ivy:buildnumber]   java.io.IOException The HTTP response code for http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
did not indicate a success. See log for more detail.
[ivy:buildnumber] CLIENT ERROR: Not Found url=http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
[ivy:buildnumber] problem while listing resources in http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
with pubRep:
[ivy:buildnumber]   java.io.IOException The HTTP response code for http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
did not indicate a success. See log for more detail

I assume the correct behavior should be accessing "http://maven.ph.co.nz/libs-releases/nz/co/uconnect/flo2cash/"

My setting is:
        <url name="pubRep">
            <artifact pattern="http://maven.ph.co.nz/libs-releases/[organisation]/[module]/[revision]/[artifact]-[revision](-[classifier]).[ext]"
/>
            <ivy pattern="http://maven.ph.co.nz/libs-releases/[organisation]/[module]/[revision]/ivy.xml"
/>
        </url>


  was:
I run "ant publish -v" and get the error message.

[ivy:buildnumber] CLIENT ERROR: Not Found url=http://maven.propellerhead.co.nz/libs-releases/nz.co.uconnect/flo2cash/
[ivy:buildnumber] problem while listing resources in http://maven.propellerhead.co.nz/libs-releases/nz.co.uconnect/flo2cash/
with pubRep:
[ivy:buildnumber]   java.io.IOException The HTTP response code for http://maven.propellerhead.co.nz/libs-releases/nz.co.uconnect/flo2cash/
did not indicate a success. See log for more detail.
[ivy:buildnumber] CLIENT ERROR: Not Found url=http://maven.propellerhead.co.nz/libs-releases/nz.co.uconnect/flo2cash/
[ivy:buildnumber] problem while listing resources in http://maven.propellerhead.co.nz/libs-releases/nz.co.uconnect/flo2cash/
with pubRep:
[ivy:buildnumber]   java.io.IOException The HTTP response code for http://maven.propellerhead.co.nz/libs-releases/nz.co.uconnect/flo2cash/
did not indicate a success. See log for more detail

I assume the correct behavior should be accessing "http://maven.propellerhead.co.nz/libs-releases/nz/co/uconnect/flo2cash/"

My setting is:
        <url name="pubRep">
            <artifact pattern="http://maven.propellerhead.co.nz/libs-releases/[organisation]/[module]/[revision]/[artifact]-[revision](-[classifier]).[ext]"
/>
            <ivy pattern="http://maven.propellerhead.co.nz/libs-releases/[organisation]/[module]/[revision]/ivy.xml"
/>
        </url>

    
> Ivy buildnumber task use wrong URL to access Artifactory repository
> -------------------------------------------------------------------
>
>                 Key: IVY-1334
>                 URL: https://issues.apache.org/jira/browse/IVY-1334
>             Project: Ivy
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.2.0
>         Environment: Windows
>            Reporter: James Gan
>             Fix For: 2.2.0
>
>
> I run "ant publish -v" and get the error message.
> [ivy:buildnumber] CLIENT ERROR: Not Found url=http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
> [ivy:buildnumber] problem while listing resources in http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
with pubRep:
> [ivy:buildnumber]   java.io.IOException The HTTP response code for http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
did not indicate a success. See log for more detail.
> [ivy:buildnumber] CLIENT ERROR: Not Found url=http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
> [ivy:buildnumber] problem while listing resources in http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
with pubRep:
> [ivy:buildnumber]   java.io.IOException The HTTP response code for http://maven.ph.co.nz/libs-releases/nz.co.uconnect/flo2cash/
did not indicate a success. See log for more detail
> I assume the correct behavior should be accessing "http://maven.ph.co.nz/libs-releases/nz/co/uconnect/flo2cash/"
> My setting is:
>         <url name="pubRep">
>             <artifact pattern="http://maven.ph.co.nz/libs-releases/[organisation]/[module]/[revision]/[artifact]-[revision](-[classifier]).[ext]"
/>
>             <ivy pattern="http://maven.ph.co.nz/libs-releases/[organisation]/[module]/[revision]/ivy.xml"
/>
>         </url>

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message