ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject DO NOT REPLY [Bug 52332] New: assertResourceExists fails using ANT 1.7.1
Date Wed, 14 Dec 2011 15:49:04 GMT

             Bug #: 52332
           Summary: assertResourceExists fails using ANT 1.7.1
           Product: Ant
           Version: 1.2
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: regression
          Priority: P2
         Component: AntUnit
    Classification: Unclassified

Created attachment 28071
Ant Unit test

We recently moved to AntUnit 1.2 using Ant 1.7.1, and an AntUnit test that used
to work is failing:
[au:antunit] ------------- ---------------- ---------------
[au:antunit] Target: test-assertions  FAILED
[au:antunit]    at line 178, column 56
[au:antunit]    Message: Expected resource '' to exist
[au:antunit]    took 0.016 sec

In fact you can use the example in the AntUnit documentation with Ant 1.7.1 and
it will fail:

Since AntUnit 1.2

Asserts that a given resource exists. This is a generalization of
assertFileExists and allows to test for arbitrary resources.

Attribute Description Required 
resource Location of the resource. Yes 
message Message for the exception if the condition doesn't hold true. Defaults
to "Expected resource 'resource' to exist". No. 

Make the build fail if the resource ${ant.home}/lib/ant.jar doesn't exist:

      <assertResourceExists resource="${ant.home}/lib/ant.jar"/>


Configure bugmail:
------- You are receiving this mail because: -------
You are the assignee for the bug.

View raw message