ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jack Frosch (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (IVY-987) Error message: "impossible to get artifacts when data has not been loaded" , on certain modules only
Date Tue, 06 Dec 2011 00:13:40 GMT

    [ https://issues.apache.org/jira/browse/IVY-987?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13163202#comment-13163202
] 

Jack Frosch commented on IVY-987:
---------------------------------

This was happening for me using Ivy 2.0.0 when a hsqldb transitive dependency was encountered
during resolve. Tried 2.1.0-rc1 and it worked fine. Thanks
                
> Error message: "impossible to get artifacts when data has not been loaded" , on certain
modules only
> ----------------------------------------------------------------------------------------------------
>
>                 Key: IVY-987
>                 URL: https://issues.apache.org/jira/browse/IVY-987
>             Project: Ivy
>          Issue Type: Bug
>    Affects Versions: 2.0
>         Environment: ubuntu 8.04, java .1.6.0_06 Java HotSpot(TM) Client VM, calling
external ant 1.7  from netbeans 6.1 IDE, ivy ant task in ants home lib dir 
>            Reporter: K. Rekk
>            Assignee: Xavier Hanin
>             Fix For: 2.1.0-RC1
>
>
> I found a similiar post here:
> http://www.mail-archive.com/ivy-user@ant.apache.org/msg01766.html
>  Everything worked fine with 2.0.0 beta .
> >
> > It's just a simple test and dom4j seems to cause the problem with
> > standard ivysettings :
> >    <dependencies>
> >        <dependency org="dom4j" name="dom4j" rev="1.6.1"/>
> >         <dependency org="log4j" name="log4j" rev="1.2.9"/>
> >        <dependency org="junit" name="junit" rev="4.5"/>
> >    </dependencies>
> > </ivy-module>
> Removing dom4j makes it work again.
> So I dont know, is it dom4j or ivy causing the problem?
> > output:
> >
> > init:
> > deps-jar:
> > ivy-retrieve:
> > No ivy:settings found for the default reference 'ivy.instance'.  A
> > default instance will be used
> > no settings file found, using default...
> > :: loading settings :: url =
> > jar:file:/home/kostja/VZG/soa-workarea-ref/tools/ant/lib/ivy-2.0.0-rc2.jar!/org/apache/ivy/core/settings/ivysettings.xml
> > :: resolving dependencies :: gbv.de#test;working@myhome
> >        confs: [default]
> >        found dom4j#dom4j;1.6.1 in public
> >        found xml-apis#xml-apis;1.0.b2 in public
> >        found jaxme#jaxme-api;0.3 in public
> >        found jaxen#jaxen;1.1-beta-6 in public
> >        found jdom#jdom;1.0 in public
> >        found xerces#xmlParserAPIs;2.6.2 in public
> >        found xerces#xercesImpl;2.6.2 in public
> >        found xom#xom;1.0b3 in public
> >        found com.ibm.icu#icu4j;2.6.1 in public
> >        found org.ccil.cowan.tagsoup#tagsoup;0.9.7 in public
> >        found msv#xsdlib;20030807 in public
> >        found msv#relaxngDatatype;20030807 in public
> >        found pull-parser#pull-parser;2 in public
> >        found xpp3#xpp3;1.1.3.3 in public
> >        found stax#stax-api;1.0 in public
> >        found log4j#log4j;1.2.9 in public
> >        found junit#junit;4.5 in public
> >
> > :: problems summary ::
> > :::: ERRORS
> >        impossible to get artifacts when data has not been loaded.
> > IvyNode = xalan#xalan;2.5.1
> > :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
> > /home/kostja/VZG/soa-workarea-ref/projects/Test/build.xml:15: impossible
> > to resolve dependencies:
> >        java.lang.IllegalStateException: impossible to get artifacts
> > when data has not been loaded. IvyNode = xalan#xalan;2.5.1
> > BUILD FAILED (total time: 0 seconds)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message