ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 51829] URLResource.connect() logs as error when URL.openConnection() fails
Date Fri, 11 Nov 2011 21:15:21 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=51829

rich@steelezone.net changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEEDINFO                    |NEW

--- Comment #2 from rich@steelezone.net 2011-11-11 21:15:21 UTC ---
Here's a script that demonstrates the problem:

<project>
    <import optional="true">
        <url file="foo.x" />
    </import>
</project>

When I run this I get:

C:\Development\projects\ant-playground\url-resource-error>ant
Buildfile: C:\Development\projects\ant-playground\url-resource-error\build.xml
java.io.FileNotFoundException:
C:\Development\projects\ant-playground\url-resource-error\foo.x (The system
cannot find the file specified)

BUILD SUCCESSFUL
Total time: 0 seconds

I made the import optional so even though the file doesn't exist the build
works.  But why print out the java.io.FileNotFoundException error message?

I have users of my build script asking me that; worse, our jenkins builds flag
that as some kind of critical problem.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Mime
View raw message