ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50542] New: Getting java.io.IOException when trying to use property environment
Date Wed, 05 Jan 2011 03:22:34 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50542

           Summary: Getting java.io.IOException when trying to use
                    property environment
           Product: Ant
           Version: 1.5.2
          Platform: PC
            Status: NEW
          Severity: blocker
          Priority: P2
         Component: Core tasks
        AssignedTo: notifications@ant.apache.org
        ReportedBy: t3knoid@yahoo.com


I am getting the following when trying to access system variables using
<property environment> task:

 [property] java.io.IOException: Cannot run program "command.com":
CreateProcess
 error=2, The system cannot find the file specified
 [property]     at java.lang.ProcessBuilder.start(Unknown Source)
 [property]     at java.lang.Runtime.exec(Unknown Source)
 [property]     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 [property]     at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
 [property]     at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown
Sourc
e)
 [property]     at java.lang.reflect.Method.invoke(Unknown Source)
 [property]     at
org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.e
xec(Execute.java:646)
 [property]     at
org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:416

Here's a simple ant project that duplicates the problem:

<project name="test" default="getenv" basedir=".">

    <target name="getenv">
        <property environment="env" />

    </target>

</project>

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Mime
View raw message