ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 50256] ant.java.version should be set to 1.5 not 1.6 when using gcj
Date Mon, 22 Nov 2010 10:25:08 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=50256

--- Comment #3 from Stefan Bodewig <bodewig@apache.org> 2010-11-22 05:25:06 EST ---
as I said on the user list, we can't simply detect "it is gij" and then
downgrade
to 1.5 because at one point in time gij may support the full feature set of
Java6.

The best thing we could do is to pick a different class that has been added
in Java6 but is not available in libgcj.

java.net.CookieStore looks good - all other things in java.lang or .util
I've checked seem to be in http://gcc.gnu.org/viewcvs/trunk/libjava/java/
as well.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Mime
View raw message