ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée (JIRA) <j...@apache.org>
Subject [jira] Resolved: (IVYDE-259) duplicate setup's added to setuplist in prefs file
Date Mon, 11 Oct 2010 08:21:33 GMT

     [ https://issues.apache.org/jira/browse/IVYDE-259?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nicolas Lalevée resolved IVYDE-259.
-----------------------------------

       Resolution: Fixed
    Fix Version/s: 2.2.0
         Assignee: Nicolas Lalevée

I think I fixed the duplicated files generation.
And also the spell mistake, thanks.

> duplicate setup's added to setuplist in prefs file
> --------------------------------------------------
>
>                 Key: IVYDE-259
>                 URL: https://issues.apache.org/jira/browse/IVYDE-259
>             Project: IvyDE
>          Issue Type: Bug
>         Environment: ivyde hudson build
>            Reporter: Stephen Haberman
>            Assignee: Nicolas Lalevée
>            Priority: Minor
>             Fix For: 2.2.0
>
>
> I'm using the latest hudson build and the new .settings/org.apache.ivyde.eclipse.prefs
file is churning a lot. In the latest diff, the setting org.apache.ivyde.eclipse.standlaoneretrieve
had changed from:
> <?xml version\="1.0" encoding\="UTF-8" standalone\="no"?>
> <setuplist>
> 	<setup name\="dependencies">
> 		<ivysettings loadondemand\="false" path\="${workspace_loc\:project/ivysettings.xml}"/>
> 		<ivyxml path\="ivy.xml"/>
> 		<retrieve confs\="*" pattern\="bin/lib/[conf]/[type]s/[artifact].[ext]" sync\="true"
types\="jar,source"/>
> 	</setup>
>         (this <setup/> was repeated 5 times)
> To the same thing but with <setup/> repeated 6 times.
> It seems to be adding new setups but not taking out the old ones. I'm not really sure
what is triggering the new (duplicate) <setup/> to be added. I just notice after using
Eclipse for awhile that the files have changed.
> Also, the setting name "standlaoneretrieve" has a typo, "laone" should be "alone".
> Apologies if I shouldn't be using the hudson build or reporting bugs for it here.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message