ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arnauld Van Muysewinkel (JIRA)" <j...@apache.org>
Subject [jira] Commented: (IVYDE-257) Trying to override old definition of task buildnumber
Date Tue, 14 Sep 2010 13:19:33 GMT

    [ https://issues.apache.org/jira/browse/IVYDE-257?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12909228#action_12909228
] 

Arnauld Van Muysewinkel commented on IVYDE-257:
-----------------------------------------------

I made additional tests and could determine that this bug is due to the additional presence
of the "Apache Ivy" plugin (not only "Apache IvyDE".

I'm doing more tests to determine with which version of that plugin the problem appears.

> Trying to override old definition of task buildnumber
> -----------------------------------------------------
>
>                 Key: IVYDE-257
>                 URL: https://issues.apache.org/jira/browse/IVYDE-257
>             Project: IvyDE
>          Issue Type: Bug
>    Affects Versions: 2.1.0
>         Environment: Eclipse 3.5SR2 (Ant 1.7.1) - JDK 1.6u2
>            Reporter: Arnauld Van Muysewinkel
>
> I create an empty project.
> The only file I have is build.xml:
> <?xml version="1.0" encoding="UTF-8"?>
> <project name="Test" default="test">
>   <target name="test" description="Test">
>     <buildnumber file="test_number.txt"/>
>   </target>
> </project>
> I start the ant build from Eclipse and get the following output:
> <<
> Buildfile: (...)\build.xml
> Trying to override old definition of task buildnumber
> test:
> BUILD FAILED
> (...)\build.xml:5: buildnumber doesn't support the "file" attribute
> >>
> It seems that the standard ant task "buildnumber" has been overrridden by Ivy.
> Given my build file, it shouldn't even try to load ivy tasks!
> I also tried to force load Ivy tasks with a prefix (adding  xmlns:ivy="antlib:org.apache.ivy.ant"
to the project definition), but to no avail.
> Note that if I start the ant build from the command line, everything is fine:
> <<
> >ant -lib (...)\eclipse-3.5\plugins\org.apache.ivy.eclipse.ant_2.2.0.cr1_20100629224905.jar
test
> [-lib (...)\eclipse-3.5\plugins\org.apache.ivy.eclipse.ant_2.2.0.cr1_20100629224905.jar]
> [-lib (...)\eclipse-3.5\plugins\org.apache.ivy.eclipse.ant_2.2.0.cr1_20100629224905.jar
test]
> Buildfile: build.xml
> test:
> BUILD SUCCESSFUL
> Total time: 0 seconds
> >ls
> build.xml  test_number.txt
> >cat test_number.txt
> #Build Number for ANT. Do not edit!
> #Tue Sep 14 14:36:15 CEST 2010
> build.number=2
> >>

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message