ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maarten Coene (JIRA)" <j...@apache.org>
Subject [jira] Commented: (IVY-1231) Ivy reports a bogus unresolved dependency
Date Wed, 22 Sep 2010 21:27:32 GMT

    [ https://issues.apache.org/jira/browse/IVY-1231?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12913803#action_12913803
] 

Maarten Coene commented on IVY-1231:
------------------------------------

Version 2.1.7 gets evicted by the dynamic "[1.3.1,)" version, which basically says: take the
latest version which is greater or equal than 1.3.1. In your repository version 5.0.4 is the
latest version.

If you want to use 2.1.7 you could specify the force attribute in your ivy.xml:

{code}
    <dependencies>
        <dependency org="net.sourceforge.itext" name="itext" rev="2.1.7" force="true" conf="default->default"/>
        <dependency org="org.jaspersoft" name="jasperreports" rev="3.5.3" conf="default->core"/>
    </dependencies>
{code}

Another approach could try to use the "latest-compatible" conflictmanager instead of the "latest-revision"
(which is the default).


> Ivy reports a bogus unresolved dependency
> -----------------------------------------
>
>                 Key: IVY-1231
>                 URL: https://issues.apache.org/jira/browse/IVY-1231
>             Project: Ivy
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.2.0-RC1
>         Environment: openSUSE 11.3, ant 1.7.1
>            Reporter: Archie Cobbs
>         Attachments: ivybug.zip
>
>
> Ivy is complaining about an unresolved dependency which does not exist:
> {noformat}
> [ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve] 		::          UNRESOLVED DEPENDENCIES         ::
> [ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
> [ivy:resolve] 		:: net.sourceforge.itext#itext;5.0.4: configuration not found in net.sourceforge.itext#itext;5.0.4:
'rtf'.
>                                     It was required from org.jaspersoft#jasperreports;3.5.3
core
> [ivy:resolve] 		::::::::::::::::::::::::::::::::::::::::::::::
> {noformat}
> There is no dependency on the "rtf" configuration in jasperreports 3.5.3 (view it's ivy.xml
file [here|http://ivyroundup.googlecode.com/svn/!svn/bc/1331/trunk/repo/modules/org.jaspersoft/jasperreports/3.5.3/ivy.xml]).
In fact, there is no dependency on any "rtf" configuration by any module in the whole repository.
> To reproduce this bug:
> # Unpack the attached ZIP file to get IVYBUG directory
> # Copy {{ivy-2.2.0-rc1.jar}} into the IVYBUG directory
> # From within IVYBUG, run {{ant}}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message