ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 49729] New: Property value resolution does not work when loading properties from a file
Date Mon, 09 Aug 2010 19:26:06 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=49729

           Summary: Property value resolution does not work when loading
                    properties from a file
           Product: Ant
           Version: 1.8.1
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: regression
          Priority: P2
         Component: Core tasks
        AssignedTo: notifications@ant.apache.org
        ReportedBy: ngrigoriev@gmail.com


Created an attachment (id=25864)
 --> (https://issues.apache.org/bugzilla/attachment.cgi?id=25864)
Sample build file and sample property file used by it

In ant 1.7.1 it was possible to load the property and to have ANT resolving its
value if it contained references to another property. In 1.8.1 this does not
seem to work anymore. Please see attached sample build file, run it with 1.7.1.
and 1.8.1 and compare the output.

1.7.1:
> c:\tools\apache-ant-1.7.1\bin\ant test

Buildfile: build.xml

test:
[echoproperties] #Ant properties
[echoproperties] #Mon Aug 09 14:51:47 EDT 2010
[echoproperties] MY_PROPERTY=123456

BUILD SUCCESSFUL
Total time: 0 seconds

1.8.1:
> c:\tools\apache-ant-1.8.1\bin\ant test
Buildfile: build.xml

test:
[echoproperties] #Ant properties
[echoproperties] #Mon Aug 09 15:24:30 EDT 2010
[echoproperties] MY_PROPERTY=${prop1}

BUILD SUCCESSFUL
Total time: 0 seconds

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Mime
View raw message