ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hi...@apache.org
Subject svn commit: r987497 - in /ant/ivy/ivyde/trunk: doc/compatibility.html org.apache.ivyde.eclipse/META-INF/MANIFEST.MF org.apache.ivyde.feature/feature.xml
Date Fri, 20 Aug 2010 13:16:18 GMT
Author: hibou
Date: Fri Aug 20 13:16:17 2010
New Revision: 987497

URL: http://svn.apache.org/viewvc?rev=987497&view=rev
Log:
IvyDE 2.2 now requires Eclipse 3.4

Modified:
    ant/ivy/ivyde/trunk/doc/compatibility.html
    ant/ivy/ivyde/trunk/org.apache.ivyde.eclipse/META-INF/MANIFEST.MF
    ant/ivy/ivyde/trunk/org.apache.ivyde.feature/feature.xml

Modified: ant/ivy/ivyde/trunk/doc/compatibility.html
URL: http://svn.apache.org/viewvc/ant/ivy/ivyde/trunk/doc/compatibility.html?rev=987497&r1=987496&r2=987497&view=diff
==============================================================================
--- ant/ivy/ivyde/trunk/doc/compatibility.html (original)
+++ ant/ivy/ivyde/trunk/doc/compatibility.html Fri Aug 20 13:16:17 2010
@@ -37,7 +37,7 @@ IvyDE expects to be used with a version 
 
 <h2>Eclipse integration</h2>
 
-IvyDE has been maintained to be compatible with Eclipse 3.2, 3.3, 3.4 and 3.5.
+IvyDE has been maintained to be compatible with Eclipse 3.4, 3.5 and 3.6.
 
 <h2>JVM compability</h2>
 

Modified: ant/ivy/ivyde/trunk/org.apache.ivyde.eclipse/META-INF/MANIFEST.MF
URL: http://svn.apache.org/viewvc/ant/ivy/ivyde/trunk/org.apache.ivyde.eclipse/META-INF/MANIFEST.MF?rev=987497&r1=987496&r2=987497&view=diff
==============================================================================
--- ant/ivy/ivyde/trunk/org.apache.ivyde.eclipse/META-INF/MANIFEST.MF (original)
+++ ant/ivy/ivyde/trunk/org.apache.ivyde.eclipse/META-INF/MANIFEST.MF Fri Aug 20 13:16:17
2010
@@ -18,25 +18,25 @@ Export-Package: org.apache.ivyde.eclipse
  org.apache.ivyde.eclipse.ui.preferences,
  org.apache.ivyde.eclipse.ui.views,
  org.apache.ivyde.eclipse.ui.wizards
-Require-Bundle: org.apache.xerces;resolution:=optional,
- org.eclipse.ui,
- org.eclipse.core.runtime,
- org.eclipse.jface.text,
- org.eclipse.ui.editors,
- org.eclipse.ui.workbench.texteditor,
- org.eclipse.core.resources,
- org.eclipse.ui.ide,
- org.eclipse.ui.forms,
- org.eclipse.search,
- org.eclipse.jdt.core,
- org.eclipse.jdt.ui,
- org.eclipse.ui.console,
+Require-Bundle: org.apache.xerces;bundle-version="[2.9.0,3.0.0)";resolution:=optional,
+ org.eclipse.ui;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.jface.text;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.editors;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.workbench.texteditor;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.ide;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.forms;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.search;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.jdt.core;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.jdt.ui;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.ui.console;bundle-version="[3.4.0,4.0.0)",
  org.apache.ivy;bundle-version="[2.1.0,3.0.0)",
- org.eclipse.help,
- org.eclipse.wst.xml.core;resolution:=optional,
- org.eclipse.debug.core,
- org.eclipse.jdt.launching,
- org.eclipse.debug.ui,
- org.eclipse.core.variables
+ org.eclipse.help;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.wst.xml.core;bundle-version="[1.1.0,2.0.0)";resolution:=optional,
+ org.eclipse.debug.core;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.jdt.launching;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.debug.ui;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.variables;bundle-version="[3.2.0,4.0.0)"
 Bundle-ActivationPolicy: lazy
 Bundle-RequiredExecutionEnvironment: J2SE-1.4

Modified: ant/ivy/ivyde/trunk/org.apache.ivyde.feature/feature.xml
URL: http://svn.apache.org/viewvc/ant/ivy/ivyde/trunk/org.apache.ivyde.feature/feature.xml?rev=987497&r1=987496&r2=987497&view=diff
==============================================================================
--- ant/ivy/ivyde/trunk/org.apache.ivyde.feature/feature.xml (original)
+++ ant/ivy/ivyde/trunk/org.apache.ivyde.feature/feature.xml Fri Aug 20 13:16:17 2010
@@ -37,22 +37,24 @@
    </url>
 
    <requires>
-      <import plugin="org.eclipse.ui"/>
-      <import plugin="org.eclipse.core.runtime"/>
-      <import plugin="org.eclipse.jface.text"/>
-      <import plugin="org.eclipse.ui.editors"/>
-      <import plugin="org.eclipse.ui.workbench.texteditor"/>
-      <import plugin="org.eclipse.core.resources"/>
-      <import plugin="org.eclipse.ui.ide"/>
-      <import plugin="org.eclipse.ui.forms"/>
-      <import plugin="org.eclipse.search"/>
-      <import plugin="org.eclipse.jdt.core"/>
-      <import plugin="org.eclipse.jdt.ui"/>
-      <import plugin="org.eclipse.ui.console"/>
-      <import plugin="org.eclipse.osgi"/>
-      <import plugin="org.apache.ant"/>
-      <import plugin="com.jcraft.jsch"/>
-      <import plugin="org.apache.ivy"/>
+      <import plugin="org.eclipse.ui" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.core.runtime" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.jface.text" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.ui.editors" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.ui.workbench.texteditor" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.core.resources" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.ui.ide" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.ui.forms" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.search" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.jdt.core" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.jdt.ui" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.ui.console" version="3.4.0" match="compatible"/>
+      <import plugin="org.apache.ivy" version="2.1.0" match="compatible"/>
+      <import plugin="org.eclipse.help" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.debug.core" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.jdt.launching" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.debug.ui" version="3.4.0" match="compatible"/>
+      <import plugin="org.eclipse.core.variables" version="3.2.0" match="compatible"/>
    </requires>
 
    <plugin



Mime
View raw message