ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maarten Coene (JIRA)" <j...@apache.org>
Subject [jira] Updated: (IVY-1177) Can't deal with [VERSION] version pattern from Maven
Date Fri, 07 May 2010 20:14:49 GMT

     [ https://issues.apache.org/jira/browse/IVY-1177?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Maarten Coene updated IVY-1177:
-------------------------------

    Fix Version/s: 2.2.0-RC1
                       (was: trunk)

> Can't deal with [VERSION] version pattern from Maven
> ----------------------------------------------------
>
>                 Key: IVY-1177
>                 URL: https://issues.apache.org/jira/browse/IVY-1177
>             Project: Ivy
>          Issue Type: Bug
>    Affects Versions: 2.1.0
>         Environment: Windows XP and Mac OS 
>            Reporter: Richard Vowles
>            Assignee: Maarten Coene
>             Fix For: 2.2.0-RC1
>
>
> If you want a specific version of a resource in Maven, [VERSION] is a valid request -
e.g. [1.5.8]
> I am using grape (from Groovy) and 
> grape -d install org.slf4j slf4j-api [1.5.8] 
> will not work. These dependencies are all over the place in our maven repo (and presumably
others). I fixed it by adding to ModuleRevisionId.java 
>     protected static String normalizeRevision(String asked) {
>         if ( asked.startsWith( "[" ) && asked.endsWith( "]" ) && asked.indexOf(',')
== -1 ) {
>             return asked.substring(1, asked.length() - 1 );
>         } else
>             return asked;
>     }
> and using it in the constructor:
> this.revision = revision == null ? Ivy.getWorkingRevision() : normalizeRevision(revision);

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message