ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fn Ord (JIRA)" <j...@apache.org>
Subject [jira] Created: (IVY-1189) Publish failing with usepoms="false" on JDK 1.5
Date Mon, 10 May 2010 18:32:30 GMT
Publish failing with usepoms="false" on JDK 1.5
-----------------------------------------------

                 Key: IVY-1189
                 URL: https://issues.apache.org/jira/browse/IVY-1189
             Project: Ivy
          Issue Type: Bug
          Components: Ant
    Affects Versions: 2.1.0
         Environment: Linux 2.6.9-55.ELsmp
 jdk1.5.0_22
standalone Hudson
Apache Archiva 1.1.3 and/or 1.3.0
            Reporter: Fn Ord


This is a weird one, and it took me a very long time to hunt down.

I have builds publishing via the ant publish target, as I have been for years.

I recently set usepoms="false" and could no longer publish artifacts. The first artifact would
publish, but any further artifacts, or the ivy.xml, would time out -- it's like the cirst
connection never closes.

Switching the JDK to 1.6 instantly fixes the publishing issue.

Removing usepoms="false" also instantly fixes the issue.

Unfortunately, neither of these are acceptable workarounds. We publish a lot of internal code
without pom files, and every time we go to resolve this code, our Maven repo scours the net
for pom files that don't exist, and some builds that should take minutes take upwards of an
hour.



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message