ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maarten Coene (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (IVY-1146) Cannot find the correct version of dependencies in pom that doesn't list versions
Date Thu, 03 Dec 2009 22:04:21 GMT

     [ https://issues.apache.org/jira/browse/IVY-1146?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Maarten Coene resolved IVY-1146.
--------------------------------

       Resolution: Duplicate
    Fix Version/s: trunk
         Assignee: Maarten Coene

The problem was caused because Ivy didn't support the 'import' scope (which was present in
one of the parent poms).
I've added support for this 'import' scope in SVN trunk. 

Could you give it a try to see if it solves your problem and post your feedback here?
Note: you might have to clean your Ivy cache first!

Maarten

> Cannot find the correct version of dependencies in pom that doesn't list versions
> ---------------------------------------------------------------------------------
>
>                 Key: IVY-1146
>                 URL: https://issues.apache.org/jira/browse/IVY-1146
>             Project: Ivy
>          Issue Type: Bug
>          Components: Maven Compatibility
>    Affects Versions: 2.1.0-RC1, 2.1.0-RC2, 2.1.0
>            Reporter: Jason Porter
>            Assignee: Maarten Coene
>             Fix For: trunk
>
>
> The weld-core pom (http://repo1.maven.org/maven2/org/jboss/weld/weld-core/1.0.0/weld-core-1.0.0.pom)
doesn't list the versions of the dependencies.  Instead they're listed in a parent pom further
up the chain (two or three IIRC).  Odd thing is it worked fine when I pulled them down from
a local artifactory install that was caching central.  It does not work when fetching straight
from central.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message