ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeffrey Sinclair (JIRA)" <>
Subject [jira] Commented: (IVYDE-187) Allow workspace resolver to skip version matcher
Date Wed, 09 Sep 2009 20:06:57 GMT


Jeffrey Sinclair commented on IVYDE-187:

Nicolas, I don't understand your workaround because I'm under the impression that IvyDE uses
the source Ivy file which is never run through the delivery mechanism when resolving in Eclipse.
I agree with Jon that this is a critical improvement to IvyDE that needs to be addressed.
My view is that out of the box, the workspace resolver should behave like the built-in 'buildlist'
Ivy Ant task which will ignore the rev attribute in dependency resolution if the module descriptor
for that dependency is in the build list without a revision specified.

> Allow workspace resolver to skip version matcher
> ------------------------------------------------
>                 Key: IVYDE-187
>                 URL:
>             Project: IvyDE
>          Issue Type: Improvement
>          Components: workspace resolver
>    Affects Versions:
>            Reporter: Phillip Webb
>         Attachments: ivyde-workspaceignoreversion.patch
> The workspace resolver version matcher sometimes gets in the way.  I would like to suggest
an option that will allow a workspace project to be used when the organization and module
ID match, regardless of the version.  
> The DocComment on WorkspaceResolver seems to imply that this was the original intent:
>   * Since the resolver is not aware which module revision a project is publishing, it
>   * matches any revision of the module.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message