ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Barry Pape (JIRA)" <j...@apache.org>
Subject [jira] Created: (IVY-1132) Ivy resolve not getting latest artifact (jar files)
Date Tue, 29 Sep 2009 22:14:07 GMT
Ivy resolve not getting latest artifact (jar files)
---------------------------------------------------

                 Key: IVY-1132
                 URL: https://issues.apache.org/jira/browse/IVY-1132
             Project: Ivy
          Issue Type: Bug
          Components: Ant
    Affects Versions: 2.1.0-RC2, trunk
         Environment: Ant 1.7.0
Artifactory 2.0.6
Ivy 2.2.x-local-20090906095736 
            Reporter: Barry Pape


I'm having trouble trying to get ivy resolve to update with the latest jars from the repository.
 If I upload an updated version of a jar, the ivy resolve does not update the cache with this
new jar.  I've searched around and tried various combinations of using attributes on the resolvers
and ivy:resolve and setting the ivy.resolver.default.check.modified property to true.  I've
also tried using some of the latest-strategies to no avail.

I've tried using:
<ivy:resolve refresh="true" resolveMode="dynamic"/>

and various combinations of (I've used the filesystem resolver as well to no avail):
        <url name="myResolver" force="true" checkmodified="true" m2compatible="true" >
force appears to be undesirable because it will update a dependency to the latest version
found in the repository and we have some legacy applications that we don't want on the latest
version of an artifact

When I use:
    <property name="ivy.resolver.default.check.modified" value="true"/> with m2compatible="true"
results in the resolve to fail for artifacts with the format org="com.something"

There is a mail list thread here that can be referenced for the complete discussion: http://www.nabble.com/Ivy-resolve-not-getting-latest-td25531231.html


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message