ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Duke Robillard (JIRA)" <j...@apache.org>
Subject [jira] Commented: (IVY-645) Ivy not working with rpm install of ant
Date Fri, 21 Aug 2009 13:48:14 GMT

    [ https://issues.apache.org/jira/browse/IVY-645?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12745970#action_12745970
] 

Duke Robillard commented on IVY-645:
------------------------------------

I had the same problem on Fedora 10; the yum installed ant didn't work with ivy...it could
never find the ivy jars, and threw the same error.

Guided by Jonathan's success on SuSE, I tried the same kind of thing:

   1) rpm -erase to get rid of the Fedora-supplied ant, 
          (I had to do:     rpm -e ant-1.7.1-7.2.fc10.i386 ant-nodeps-1.7.1-7.2.fc10.i386
 ant-junit-1.7.1-7.2.fc10.i386)
   2)  downloaded ant from Apache, put it in /opt/ant,
   3)  copied the ivy-related jars to /opt/ant/lib.   

Now when I run /opt/ant/bin/ant, ivy works okay

I guess this this should be on the Fedora ans SuSE bug sites, but during my Googling about
the problem, I found this, so I figured I'd add some info to try to help out other ant/ivy
sufferers.



> Ivy not working with rpm install of ant
> ---------------------------------------
>
>                 Key: IVY-645
>                 URL: https://issues.apache.org/jira/browse/IVY-645
>             Project: Ivy
>          Issue Type: Bug
>          Components: Ant
>    Affects Versions: 2.0.0-alpha-2
>         Environment: openSuse 10.3, ant 1.7.0
>            Reporter: Jonathan Doklovic
>
> After installing ant via the package manager (Yast2) and adding the ivy jar to /usr/share/ant/lib
ant doesn't find ivy on the classpath and no ivy tasks will work.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message