ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maarten Coene (JIRA)" <>
Subject [jira] Resolved: (IVY-1102) ivy parse exception when using <publications defaultconf>
Date Mon, 03 Aug 2009 07:01:14 GMT


Maarten Coene resolved IVY-1102.

       Resolution: Fixed
    Fix Version/s: trunk
         Assignee: Maarten Coene

This should be fixed in SVN trunk.
Could you give it a try?


> ivy parse exception when using <publications defaultconf>
> ---------------------------------------------------------
>                 Key: IVY-1102
>                 URL:
>             Project: Ivy
>          Issue Type: Bug
>            Reporter: Shawn Castrianni
>            Assignee: Maarten Coene
>             Fix For: trunk
> I have an ivy.xml file that uses the somewhat new feature of defaultconf in the publications
XML tag.  This allows a default conf settings for all publications that do not specify one.
 When using this AND not publishing all configurations, I get this:
> 16:39:32,3 [lgcbuild-publish-repository@buildmaster2:8080] WARN - /d01/QuickBuild/workspace/root/lgcbuilds/lgcbuild/lgcbuild/ivy/build/master.xml:2793:
impossible to publish artifacts for Landmark#jTableTools#HEAD;working@buildmaster2: java.lang.IllegalStateException:
bad ivy file for Landmark#jTableTools#HEAD;working@buildmaster2: /d01/QuickBuild/workspace/root/lgcbuilds/DSInfrastructure/jTableTools/DS_5000_4_0_0/jTableTools/build/module/ivy/ivy.xml:
java.text.ParseException: Cannot add artifact 'module.xml(homes)' to configuration 'all' of
module Landmark#jTableTools#HEAD;DS_5000_4_0_0.HEAD.090710.1 because this configuration doesn't
exist! in file:/d01/QuickBuild/workspace/root/lgcbuilds/DSInfrastructure/jTableTools/DS_5000_4_0_0/jTableTools/build/module/ivy/ivy.xml
> In my example, I have:
> <publications defaultconf="all,win32,win64,linux,linux64,solaris">
> but in this case, I am only trying to publish configurations generic and linux64.  Therefore,
my delivered ivy file only has those two conf defined:
>         <configurations>
>                 <conf name="generic"/>
>                <conf name="linux64"/>
>         </configurations>
> This is causing the error above.
> If I remove the defaultconf and put the conf by all the artifacts, this problem goes

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message