ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 47546] New: Not able to get <classTest>.xml and ALLTest.xml files in target folders in JMUnit and getting <classname> FAILED in JUnit
Date Fri, 17 Jul 2009 07:45:59 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=47546

           Summary: Not able to get <classTest>.xml and ALLTest.xml files
                    in target folders in JMUnit and getting <classname>
                    FAILED in JUnit
           Product: Ant
           Version: 1.7.0
          Platform: PC
        OS/Version: Windows XP
            Status: UNCONFIRMED
          Severity: critical
          Priority: P2
         Component: AntUnit
        AssignedTo: notifications@ant.apache.org
        ReportedBy: divyabhatt16@gmail.com


I am implementing example code of JMunit v1.2 for my j2me applications unit
tetsing, in which when i try to run build.xml i dont get <classTest>.xml and
ALLTest.xml files in target folders.

by the patch:-

<target name="jmunit_task" depends="compile">
      <jmunit haltonerror="false" haltonfailure="false"
failureproperty="testfailure">

         <classpath>
            <path path="classes" />
         </classpath>                  

         <test name="com.foo.BarTest" todir="test_results_jmunit" />
         <test name="com.foo.FooTest" todir="test_results_jmunit" />
      </jmunit>
   </target>

AND

 <target name="packagetests" depends="jmunit_task">
      <wtkjad jadfile="dist/alltests.jad" jarfile="dist/alltests.jar"
name="AllTests" vendor="CAM" version="1.0.0">
         <midlet name="AllTests" class="com.foo.SuiteRunner" />
      </wtkjad>
      <wtkpackage jarfile="dist/alltests.jar" jadfile="dist/alltests.jad"
preverify="true" obfuscate="false">
         <libclasspath>
            <path path="lib/jmunit4cldc10-${version}.jar" />
         </libclasspath>
         <fileset dir="classes"/>
      </wtkpackage>
   </target>


So from the above patches of build.xml, i am not able to get files in
destination folders, please let me knwo why??

Apart from this, when i try to run target "jmunit_task" with JUNit and not by
JMUnit than i able to get <classText>.xml but with errors
{java.lang.NoClassDefFoundError: jmunit/framework/cldc10/TestCase }
The patch is :-
<target name="jmunit_task" depends="compile">
   <junit printsummary="yes" haltonerror="false" haltonfailure="false"
failureproperty="testfailure">               

       <classpath>
            <path path="classes" />
         </classpath>             

  <test name="com.foo.BarTest" todir="test_results_jmunit">  
    <formatter type="xml"/>
  </test>      
</junit>
 </target>


Please help me why I am getting errors though i set all the required paths in
build.xml and also in Classpath of teh system.

Attached is a build.xml with this page.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

Mime
View raw message