ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject DO NOT REPLY [Bug 47196] New: Can't use <packageset> to exclude packages from <javadoc> in 1.7.1, ok in 1.6
Date Thu, 14 May 2009 17:12:57 GMT

           Summary: Can't use <packageset> to exclude packages from
                    <javadoc> in 1.7.1, ok in 1.6
           Product: Ant
           Version: 1.7.1
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: critical
          Priority: P5
         Component: Core tasks

I have the following <javadoc> command and am specifying a number of packages
to exclude from the javadoc. This works fine in Ant 1.6.1 but not in 1.7.1. I'm
running with java 1.5.0_16. For some reason, the packages I specify in the
<exclude> of the <packageset> aren't being excluded in 1.7.1, but are in 1.6.1.

<property name="doc.params.deploy" value="-d deploy/doc/api -breakiterator
-author -generic -docletpath
-doclet ydoc.doclets.YStandard -filterpath ydoc-3.0_01-jdk1.5/lib/ydoc.jar
-filter ydoc.filters.ExcludeFilter 
-tag y.precondition 
-tag y.postcondition 
-tag param
-tag return
-tag see
-windowtitle 'Armanta Application Framework API'
-doctitle 'Armanta Application Framework API'
-bottom 'Copyright 2009 Armanta, Inc. All rights reserved.'


<javadoc sourcepath="source/java" destdir="deploy/doc/api" windowtitle="Armanta
Application Framework API" doctitle="Armanta Application Framework API"
encoding="iso-8859-1" docencoding="iso-8859-1"
     bottom="Copyright (c) 2009 Armanta, Inc.."  
     additionalparam="${doc.params.deploy}" classpathref="build-classpath" 
     <packageset dir="source/java" defaultexcludes="yes">
              <exclude name="com/armanta"/>
              <exclude name="com/armanta/app"/>

Configure bugmail:
------- You are receiving this mail because: -------
You are the assignee for the bug.

View raw message