ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée (JIRA) <j...@apache.org>
Subject [jira] Resolved: (IVYDE-173) IvyDE: impossible to put metadata file in cache when using branches
Date Tue, 31 Mar 2009 13:56:01 GMT

     [ https://issues.apache.org/jira/browse/IVYDE-173?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nicolas Lalevée resolved IVYDE-173.
-----------------------------------

    Resolution: Duplicate

IvyDE wasn't managing correctly the defaultBranch parameter: it has been fixed with IVYDE-168

> IvyDE: impossible to put metadata file in cache when using branches
> -------------------------------------------------------------------
>
>                 Key: IVYDE-173
>                 URL: https://issues.apache.org/jira/browse/IVYDE-173
>             Project: IvyDE
>          Issue Type: Bug
>          Components: classpath container
>    Affects Versions: 2.0.0.beta1
>         Environment: windows, Rational Application Developer 7.0, ant1.7
>            Reporter: Marc De Boeck
>            Priority: Minor
>
> I am having problems to resolve some dependencies with IvyDE (since this looks like a
 small bug, I posted it immediately to JIRA, instead of first asking advice to the user-group):
> The IvyDE console gives me the following error:
> :: problems summary ::
> :::: WARNINGS
> 	impossible to put metadata file in cache: R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\..\..\oobs_repo\ibm\sib-utils\2.0.0\ivy.xml
(2.0.0). java.io.FileNotFoundException: R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\var\cache\repository\ibm\sib-utils\C2.0\ivy-2.0.0.xml.original
(The system cannot find the file specified.)
> 	impossible to put metadata file in cache: R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\..\..\oobs_repo\spring\spring-oxm\1.0.3\ivy.xml
(1.0.3). java.io.FileNotFoundException: R:\ext950_r_costa_INCEPTION_int_dn\devtools\oobs\var\cache\repository\spring\spring-oxm\C2.0\ivy-1.0.3.xml.original
(The system cannot find the file specified.)
> :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
> The artifacts are properly downloaded to my cache, but even subsequent resolve operations
keep complaining about this ivy.xml.original file.
> If I execute ivy:resolve via ant, then the resolve works fine, and the ivy.xml and artifacts
are copied properly to my cache.
> After that, also the resolve via IvyDE doesn't complain anymore.
> The special thing about our environment is that in the ivy-settings, there is a setting
for a defaultBranch (equal to C2.0).
> I looks like Ivy(DE) is initialy copying the ivy.xml file from the repository to the
following location to my cache in the directory:
> [org]/[module]/ivy-[revision].xml.original
> (because that's where I find the ivy.xml)
> But then, to make a static ivy.xml file, it looks for that file in:
> [org]/[module]/*[branch]*/ivy-[revision].xml.original
> Forcing explicitly the artifactPattern in the ivy-settings file seems to solve my problem,
but it is not consistent:
> This ivyPattern works well:
> ivyPattern="[organisation]/[module]/ivy-[revision].xml"
> This ivyPattern gives the warning in IvyDE (not with ant):
> ivyPattern="[organisation]/[module]/[branch]/ivy-[revision].xml"
> There is also an issue with the fact that the documentation mentions that the default
artifactPattern is [organisation]/[module]/ivy-[revision].xml, while it seems to be [organisation]/[module]/[branch]/ivy-[revision].xml
(I'll make a separate documentation issue for Ivy for this one).
> Thanks,
> Marc

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message