ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée (JIRA) <j...@apache.org>
Subject [jira] Resolved: (IVYDE-168) Branch in repository pattern and defaultBranch
Date Thu, 05 Mar 2009 15:53:56 GMT

     [ https://issues.apache.org/jira/browse/IVYDE-168?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nicolas Lalevée resolved IVYDE-168.
-----------------------------------

       Resolution: Fixed
    Fix Version/s: 2.0.0.final
         Assignee: Nicolas Lalevée

Bug reproduced and fixed. Thanks for reporting it.

> Branch in repository pattern and defaultBranch
> ----------------------------------------------
>
>                 Key: IVYDE-168
>                 URL: https://issues.apache.org/jira/browse/IVYDE-168
>             Project: IvyDE
>          Issue Type: Bug
>    Affects Versions: 2.0.0.beta1
>            Reporter: Juha Ranta
>            Assignee: Nicolas Lalevée
>             Fix For: 2.0.0.final
>
>
> Let's suppose that you have branch in the repository pattern, as in "[organisation]/[module]/[branch]/[revision]/[type]s/[artifact].[ext]",
and you have also set defaultBranch in ivysettings like this:
> <settings defaultBranch="trunk"/>
> If you have a dependency without a branch tag and a static revision, then IvyDE seems
to insert an empty string as branch in the repository pattern while doing resolve which causes
an error. For instance,  if you have a dependency such as this:
> <dependency org="myorg" name="mymod" rev="10.2"/>
> Then IvyDE tries to find it in "myorg/mymod//10.2". I think it should try to find it
in "myorg/mymod/trunk/10.2" instead, which is the way the normal Ivy resolve from an Ant script
works. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message