ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Danno Ferrin (JIRA)" <j...@apache.org>
Subject [jira] Created: (IVY-1041) Maven POM classifier being translated incorrectly from a pom to an ivy.xml file
Date Wed, 04 Mar 2009 22:13:56 GMT
Maven POM classifier being translated incorrectly from a pom to an ivy.xml file
-------------------------------------------------------------------------------

                 Key: IVY-1041
                 URL: https://issues.apache.org/jira/browse/IVY-1041
             Project: Ivy
          Issue Type: Bug
          Components: Maven Compatibility
    Affects Versions: 2.0
         Environment: Windows vista, Ivy 2.0.0, java 6.0u12
            Reporter: Danno Ferrin


It appears that the translation from a Maven POM to an Ivy file is placing the m:classifier
attribute on the artifact element rather than the dependency element, where ivy handles it.
 To reproduce:

{code}java -jar <path-to>/ivy-2.0.0.jar -settings mule-core-ivy-settings.xml -dependency
org.mule mule-core 2.2.0{code}

The mule-core-ivy-settings.xml file is:
{code}<?xml version="1.0" encoding="utf-8"?>
<ivysettings>
 <settings defaultResolver="downloadGrapes" />
 <resolvers>
   <chain name="downloadGrapes">
     <ibiblio name="codehaus" root="http://repository.codehaus.org/" m2compatible="true"
/>
     <ibiblio name="ibiblio" m2compatible="true" />
     <ibiblio name="java.net2" root="http://download.java.net/maven/2/" m2compatible="true"
/>
     <ibiblio name="mule-osgi-deps" root="http://dist.codehaus.org/mule/dependencies/maven2"
m2compatible="true"/>
   </chain>
 </resolvers>
</ivysettings>{code}

The relevant error output isis...
{code}:: problems summary ::
:::: WARNINGS
                module not found: org.safehaus.jug#jug;2.0.0-osgi

        ==== codehaus: tried

          http://repository.codehaus.org/org/safehaus/jug/jug/2.0.0-osgi/jug-2.0.0-osgi.pom

          -- artifact org.safehaus.jug#jug;2.0.0-osgi!jug.jar:

          http://repository.codehaus.org/org/safehaus/jug/jug/2.0.0-osgi/jug-2.0.0-osgi.jar

        ==== ibiblio: tried

          http://repo1.maven.org/maven2/org/safehaus/jug/jug/2.0.0-osgi/jug-2.0.0-osgi.pom

          -- artifact org.safehaus.jug#jug;2.0.0-osgi!jug.jar:

          http://repo1.maven.org/maven2/org/safehaus/jug/jug/2.0.0-osgi/jug-2.0.0-osgi.jar

        ==== java.net2: tried

          http://download.java.net/maven/2/org/safehaus/jug/jug/2.0.0-osgi/jug-2.0.0-osgi.pom

          -- artifact org.safehaus.jug#jug;2.0.0-osgi!jug.jar:

          http://download.java.net/maven/2/org/safehaus/jug/jug/2.0.0-osgi/jug-2.0.0-osgi.jar

        ==== mule-osgi-deps: tried

          http://dist.codehaus.org/mule/dependencies/maven2/org/safehaus/jug/jug/2.0.0-osgi/jug-2.0.0-osgi.pom

          -- artifact org.safehaus.jug#jug;2.0.0-osgi!jug.jar:

          http://dist.codehaus.org/mule/dependencies/maven2/org/safehaus/jug/jug/2.0.0-osgi/jug-2.0.0-osgi.jar

                ::::::::::::::::::::::::::::::::::::::::::::::

                ::          UNRESOLVED DEPENDENCIES         ::

                ::::::::::::::::::::::::::::::::::::::::::::::

                :: org.safehaus.jug#jug;2.0.0-osgi: not found

                ::::::::::::::::::::::::::::::::::::::::::::::{code}

In the generated org.mule/mule-core/ivy-2.2.0.xml the following line is generated as
{code}<dependency org="org.safehaus.jug" name="jug" rev="2.0.0-osgi" force="true" conf="compile->compile(*),master(*);runtime->runtime(*)">
    <artifact name="jug" type="jar" ext="jar" conf="" m:classifier="asl"/>
</dependency>{code}
but it works if {{m:classifier}} is move to the {{dependency}} element:
{code}<dependency org="org.safehaus.jug" name="jug" rev="2.0.0-osgi" force="true" conf="compile->compile(*),master(*);runtime->runtime(*)"
m:classifier="asl">
    <artifact name="jug" type="jar" ext="jar" conf=""/>
</dependency>{code}


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message