ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maarten Coene (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (IVY-1009) Ivy Standalone hangs after publishing to SSH resolver
Date Wed, 04 Feb 2009 21:34:00 GMT

     [ https://issues.apache.org/jira/browse/IVY-1009?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Maarten Coene resolved IVY-1009.
--------------------------------

       Resolution: Fixed
    Fix Version/s: trunk

I think I solved it be adding an explicit System.exit(0) at the end of the main-method.
There was probably something still hanging around...

Could you give it a try, since I couldn't test it to see if it is really solved.

> Ivy Standalone hangs after publishing to SSH resolver
> -----------------------------------------------------
>
>                 Key: IVY-1009
>                 URL: https://issues.apache.org/jira/browse/IVY-1009
>             Project: Ivy
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.0-RC2, 2.0
>         Environment: Windows XP, standalone ivy. SSH server running on CentOS 5
>            Reporter: Nathan Tomkins
>            Assignee: Maarten Coene
>             Fix For: trunk
>
>
> I'm using Ivy in standalone mode to manage DLLs for a C# project. I have an SSH repository
set up, which works fine for retrieving artifacts, but not for publishing them.
> When I publish a module, everything succeeds as expected, however ivy doesn't exit and
return to the command prompt. If ivy is run with -verbose or -debug, the last thing it prints
to the console is "publish done (12273ms)".

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message