ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lewis Denizen (JIRA)" <j...@apache.org>
Subject [jira] Commented: (IVYDE-154) Retrieve not using correct configuration
Date Tue, 13 Jan 2009 01:54:59 GMT

    [ https://issues.apache.org/jira/browse/IVYDE-154?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12663182#action_12663182
] 

Lewis Denizen commented on IVYDE-154:
-------------------------------------

Seems like explicitly setting it retrieveConfs in .classpath works (always reverts to * when
I try it from the UI):

	<classpathentry kind="con" path="org.apache.ivyde.eclipse.cpcontainer.IVYDE_CONTAINER/?ivyXmlPath=ivy.xml&amp;confs=default&amp;doRetrieve=true&amp;retrievePattern=lib%2F%5Bconf%5D%2F%5Bartifact%5D.%5Bext%5D&amp;retrieveSync=false&amp;retrieveConfs=default&amp;retrieveTypes=*"/>

But thanks, this solves the issue in the short term :-)  Great work on the plug-in (really
helps to simplify Ivy)!

> Retrieve not using correct configuration
> ----------------------------------------
>
>                 Key: IVYDE-154
>                 URL: https://issues.apache.org/jira/browse/IVYDE-154
>             Project: IvyDE
>          Issue Type: Bug
>          Components: classpath container
>    Affects Versions: 2.0.0.beta1
>         Environment: Eclipse 3.4.1
>            Reporter: Lewis Denizen
>
> When I select only a single configuration in the project-specific IvyDE Managed Libraries,
the resolve task acknowledges the configuration chosen, but the retrieve task doesn't appear
to use the specific configuration - it defaults to using *.  This fails and throws an exception
if the other configurations haven't been resolved in the past, since the *[config-name].xml
configuration is not created in cache (ex. myproj-test.xml).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message