ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée (JIRA) <j...@apache.org>
Subject [jira] Commented: (IVYDE-154) Retrieve not using correct configuration
Date Sat, 10 Jan 2009 08:47:59 GMT

    [ https://issues.apache.org/jira/browse/IVYDE-154?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12662637#action_12662637
] 

Nicolas Lalevée commented on IVYDE-154:
---------------------------------------

In fact you are hitting a two bugs: IVYDE-137, IVYDE-140.
The work around:
* in the configuration list for the resolve, select also the configuration you want for the
retrieve.
* in the configuration list for the retrieve, do not use '*' but specify some existing configuration

> Retrieve not using correct configuration
> ----------------------------------------
>
>                 Key: IVYDE-154
>                 URL: https://issues.apache.org/jira/browse/IVYDE-154
>             Project: IvyDE
>          Issue Type: Bug
>          Components: classpath container
>    Affects Versions: 2.0.0.beta1
>         Environment: Eclipse 3.4.1
>            Reporter: Lewis Denizen
>
> When I select only a single configuration in the project-specific IvyDE Managed Libraries,
the resolve task acknowledges the configuration chosen, but the retrieve task doesn't appear
to use the specific configuration - it defaults to using *.  This fails and throws an exception
if the other configurations haven't been resolved in the past, since the *[config-name].xml
configuration is not created in cache (ex. myproj-test.xml).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message