ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Damm (JIRA)" <j...@apache.org>
Subject [jira] Updated: (IVY-972) ivy:install deletes artifacts in some cases
Date Tue, 18 Nov 2008 01:52:44 GMT

     [ https://issues.apache.org/jira/browse/IVY-972?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Benjamin Damm updated IVY-972:
------------------------------

    Description: 
Some configuration of my repository, which is getting rather complex, has opened up a corner
case where existing artifacts are deleted when I'm installing new artifacts.  Here is an ant
-v output from such an event:

[ivy:install] :: downloading artifacts to cache ::
[ivy:install]   [NOT REQUIRED] javax.servlet#jstl;1.1.0!jstl.jar
[ivy:install]   [NOT REQUIRED] javax.servlet#jsp-api;2.0!jsp-api.jar
[ivy:install]   [NOT REQUIRED] javax.servlet#servlet-api;2.4!servlet-api.jar
[ivy:install] :: installing in ivycontrib_m2 ::
[ivy:install] installing javax.servlet#jstl;1.1.0
[ivy:install] ivycontrib_m2 do not support transaction. overwrite transaction not supported
yet
[ivy:install]   published jstl to /home/bdamm/workspace/main/eng/contrib/../contrib/m2/javax.servlet/jstl/1.1.0/jars/jstl-1.1.0.jar
[ivy:install]   published ivy to /home/bdamm/workspace/main/eng/contrib/../contrib/m2/javax.servlet/jstl/1.1.0/ivy.xml
[ivy:install] installing javax.servlet#jsp-api;2.0
[ivy:install]   published jsp-api to /home/bdamm/workspace/main/eng/contrib/../contrib/m2/javax.servlet/jsp-api/2.0/jars/jsp-api-2.0.jar
[ivy:install]   published ivy to /home/bdamm/workspace/main/eng/contrib/../contrib/m2/javax.servlet/jsp-api/2.0/ivy.xml
[ivy:install] installing javax.servlet#servlet-api;2.4

The artifact javax.servlet#servlet-api;2.4 is then not found because it has been deleted,
so an exception is thrown (FileNotFound) and the build ends.

I will try to include more information here as I can whittle down my configuration to specific
and repeatable cases.  It will take time because I am already in an aggressive time crunch.



  was:
Some configuration of my repository, which is getting rather complex, has opened up a corner
case where existing artifacts are deleted when I'm installing new artifacts.  Here is an ant
-d output from such an event:

[ivy:install] :: downloading artifacts to cache ::
[ivy:install]   [NOT REQUIRED] javax.servlet#jstl;1.1.0!jstl.jar
[ivy:install]   [NOT REQUIRED] javax.servlet#jsp-api;2.0!jsp-api.jar
[ivy:install]   [NOT REQUIRED] javax.servlet#servlet-api;2.4!servlet-api.jar
[ivy:install] :: installing in ivycontrib_m2 ::
[ivy:install] installing javax.servlet#jstl;1.1.0
[ivy:install] ivycontrib_m2 do not support transaction. overwrite transaction not supported
yet
[ivy:install]   published jstl to /home/bdamm/workspace/main/eng/contrib/../contrib/m2/javax.servlet/jstl/1.1.0/jars/jstl-1.1.0.jar
[ivy:install]   published ivy to /home/bdamm/workspace/main/eng/contrib/../contrib/m2/javax.servlet/jstl/1.1.0/ivy.xml
[ivy:install] installing javax.servlet#jsp-api;2.0
[ivy:install]   published jsp-api to /home/bdamm/workspace/main/eng/contrib/../contrib/m2/javax.servlet/jsp-api/2.0/jars/jsp-api-2.0.jar
[ivy:install]   published ivy to /home/bdamm/workspace/main/eng/contrib/../contrib/m2/javax.servlet/jsp-api/2.0/ivy.xml
[ivy:install] installing javax.servlet#servlet-api;2.4

The artifact javax.servlet#servlet-api;2.4 is then not found because it has been deleted,
so an exception is thrown (FileNotFound) and the build ends.

I will try to include more information here as I can whittle down my configuration to specific
and repeatable cases.  It will take time because I am already in an aggressive time crunch.




> ivy:install deletes artifacts in some cases
> -------------------------------------------
>
>                 Key: IVY-972
>                 URL: https://issues.apache.org/jira/browse/IVY-972
>             Project: Ivy
>          Issue Type: Bug
>          Components: Ant
>    Affects Versions: 2.0-RC2
>         Environment: Linux, ubuntu
>            Reporter: Benjamin Damm
>
> Some configuration of my repository, which is getting rather complex, has opened up a
corner case where existing artifacts are deleted when I'm installing new artifacts.  Here
is an ant -v output from such an event:
> [ivy:install] :: downloading artifacts to cache ::
> [ivy:install]   [NOT REQUIRED] javax.servlet#jstl;1.1.0!jstl.jar
> [ivy:install]   [NOT REQUIRED] javax.servlet#jsp-api;2.0!jsp-api.jar
> [ivy:install]   [NOT REQUIRED] javax.servlet#servlet-api;2.4!servlet-api.jar
> [ivy:install] :: installing in ivycontrib_m2 ::
> [ivy:install] installing javax.servlet#jstl;1.1.0
> [ivy:install] ivycontrib_m2 do not support transaction. overwrite transaction not supported
yet
> [ivy:install]   published jstl to /home/bdamm/workspace/main/eng/contrib/../contrib/m2/javax.servlet/jstl/1.1.0/jars/jstl-1.1.0.jar
> [ivy:install]   published ivy to /home/bdamm/workspace/main/eng/contrib/../contrib/m2/javax.servlet/jstl/1.1.0/ivy.xml
> [ivy:install] installing javax.servlet#jsp-api;2.0
> [ivy:install]   published jsp-api to /home/bdamm/workspace/main/eng/contrib/../contrib/m2/javax.servlet/jsp-api/2.0/jars/jsp-api-2.0.jar
> [ivy:install]   published ivy to /home/bdamm/workspace/main/eng/contrib/../contrib/m2/javax.servlet/jsp-api/2.0/ivy.xml
> [ivy:install] installing javax.servlet#servlet-api;2.4
> The artifact javax.servlet#servlet-api;2.4 is then not found because it has been deleted,
so an exception is thrown (FileNotFound) and the build ends.
> I will try to include more information here as I can whittle down my configuration to
specific and repeatable cases.  It will take time because I am already in an aggressive time
crunch.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message