ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Newport (JIRA)" <j...@apache.org>
Subject [jira] Commented: (IVYDE-108) IvyDE crashes during resolve
Date Fri, 01 Aug 2008 15:12:32 GMT

    [ https://issues.apache.org/jira/browse/IVYDE-108?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12619038#action_12619038
] 

Paul Newport commented on IVYDE-108:
------------------------------------

I am getting an error if I do a manual resolve, so IvyDe is probably just not reporting the
error properly:

---------------------------------------------------------------------
[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve] [FAILED     ] org.jboss.util#com.springsource.org.jboss.util;2.0.4.GA!com.springsource.org.jboss.util.jar:
invalid sha1: expected=facdf42540e71da727dae30fc1bd5f4372bf4cf5 computed=d564edde2632855bededee87c0cced5a5cc14a4d
(10344ms)
[ivy:resolve] [FAILED     ] org.jboss.util#com.springsource.org.jboss.util;2.0.4.GA!com.springsource.org.jboss.util.jar:
 (0ms)
[ivy:resolve] ==== teamivy: tried
[ivy:resolve] \\tgcrepd1\ivy-repository/repositoryivy/org.jboss.utilcom.springsource.org.jboss.util/2.0.4.GA/com.springsource.org.jboss.util-2.0.4.GA.jar
[ivy:resolve] ==== com.springsource.repository.bundles.release: tried
[ivy:resolve] http://repository.springsource.com/ivy/bundles/release/org.jboss.util/com.springsource.org.jboss.util/2.0.4.GA/com.springsource.org.jboss.util-2.0.4.GA.jar
[ivy:resolve] ==== com.springsource.repository.bundles.external: tried
[ivy:resolve] http://repository.springsource.com/ivy/bundles/external/org.jboss.util/com.springsource.org.jboss.util/2.0.4.GA/com.springsource.org.jboss.util-2.0.4.GA.jar
[ivy:resolve] ==== com.springsource.repository.libraries.release: tried
[ivy:resolve] http://repository.springsource.com/ivy/libraries/release/org.jboss.util/com.springsource.org.jboss.util/2.0.4.GA/com.springsource.org.jboss.util-2.0.4.GA.jar
[ivy:resolve] ==== com.springsource.repository.libraries.external: tried
[ivy:resolve] http://repository.springsource.com/ivy/libraries/external/org.jboss.util/com.springsource.org.jboss.util/2.0.4.GA/com.springsource.org.jboss.util-2.0.4.GA.jar
[ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] ::              FAILED DOWNLOADS            ::
[ivy:resolve] :: ^ see resolution messages for details  ^ ::
[ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] :: org.jboss.util#com.springsource.org.jboss.util;2.0.4.GA!com.springsource.org.jboss.util.jar
[ivy:resolve] ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

> IvyDE crashes during resolve
> ----------------------------
>
>                 Key: IVYDE-108
>                 URL: https://issues.apache.org/jira/browse/IVYDE-108
>             Project: IvyDE
>          Issue Type: Bug
>    Affects Versions: 2.0.0.alpha1
>         Environment: IBM Eclipse RAD 7 which is 3.2 based, Windows XP
>            Reporter: Paul Newport
>            Priority: Blocker
>         Attachments: ivy.xml
>
>
> I changed ivy.xml to add in a new dependency and saved it. Ivy starts resolving, and
then comes up with an error dialog:
> "The resolve job has unexpectedly stopped"
> Looking in the .log of the workspace it says:
> !ENTRY org.apache.ivyde.eclipse 1 0 2008-08-01 15:18:10.864
> !MESSAGE resolved dependencies of ivy.xml
> !ENTRY org.apache.ivyde.eclipse 4 4 2008-08-01 15:18:10.864
> !MESSAGE The resolve job has unexpectedly stopped
> !STACK 0
> java.lang.NoSuchMethodError: org/eclipse/core/runtime/Status.<init>(ILjava/lang/String;Ljava/lang/String;)V
> 	at org.apache.ivyde.eclipse.cpcontainer.IvyResolveJob$1.run(Unknown Source)
> I've raised this as a blocker as the bug stops me from using IvyDe at all for this project

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message