ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée (JIRA) <>
Subject [jira] Commented: (IVYDE-98) Inclusion of ivysettings files in a main ivysettings.xml does not work.
Date Fri, 29 Aug 2008 11:02:47 GMT


Nicolas Lalevée commented on IVYDE-98:

Could it be related to IVYDE-52 ?

In the ivy console, does ivy complains about failing to load that file ? If it does, which
file path it tries to load ?

And can you test that IVYDE-52 is the bottom of the issue please: start eclipse while your
are in the directory where your settings belongs, so the "current dir" will be the ivy settings
one, and probably Ivy will then be able to find your files.

> Inclusion of ivysettings files in a main ivysettings.xml does not work.
> -----------------------------------------------------------------------
>                 Key: IVYDE-98
>                 URL:
>             Project: IvyDE
>          Issue Type: Bug
>    Affects Versions: 2.0.0.alpha1
>            Reporter: Erik-Berndt Scheper
>             Fix For: 2.0
> Inclusion of ivy settings file in IVYDE does not work (using a file or http reference).

> Note: inclusion of properties does work, but apparently only when using a URL.
> E.g. when I include my namespaces as follows:
> {code:xml}
> <ivysettings>
> 	<properties file="" />
> 	<include file="./ivy.settings.namespaces.xml"/>
> </ivysettings>
> {code}
> this works fine in batch mode (using ant), but fails in IVYDE.
> Console message:
> : problems summary ::
> 	namespace not found for joda-time#joda-time;1.5.2:
> 	namespace not found for org.junit#junit;4.4:

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message