ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Maarten Coene (JIRA)" <>
Subject [jira] Commented: (IVY-880) Ivy is no longer compatible with httpclient 2.x
Date Mon, 25 Aug 2008 22:13:44 GMT


Maarten Coene commented on IVY-880:

For the moment, I've updated URLHandlerRegistry so that it will only return HttpClientHandler
when httpclient-3.x is on the classpath...
This way we avoid problems like NoSuchMethodErrors when users have httpclient-2.x on their

> Ivy is no longer compatible with httpclient 2.x
> -----------------------------------------------
>                 Key: IVY-880
>                 URL:
>             Project: Ivy
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.0.0-beta-2
>            Reporter: Maarten Coene
> I have several compilation errors when trying to compile org.apache.ivy.util.url.HttpClientHandler
with httpclient-2.0.
> I see 2 options:
> - update the code to be compatible with both 2.x and 3.x (maybe create a HttpClient2Handler
and HttpClient3Handler class and compile both of them with the appropriate httpclient.jar
to avoid this same problem in the future again)
> - don't try to be compatible with httpclient 2.x any longer

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message