ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 45495] New: Ant showing garbage I18N characters when option "-propertyfile" is used.
Date Mon, 28 Jul 2008 21:50:50 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=45495

           Summary: Ant showing garbage I18N characters when option "-
                    propertyfile" is used.
           Product: Ant
           Version: unspecified
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P3
         Component: Core
        AssignedTo: notifications@ant.apache.org
        ReportedBy: yunpeng.zhang@sun.com


Sample testing Ant script:

<project>
    <target name="echo">
        <echo message="The input is: ${input}"/>
    </target>

</project>

Sample testing input property file:

input=部件名

The issue is found in both 1.7.1 and 1.6.5.

The problem:

1. If we put "input=部件名" in a property file and invoke ant using
"-propertyfile" option, we got garbage output, please see the following:

.\ant -f input.xml -propertyfile test.txt echo
Buildfile: input.xml

echo:
     [echo] The input is: ??????

BUILD SUCCESSFUL
Total time: 0 seconds

2. If we give the input ("input=部件名") directly from the ant command line,
everything just went fine, please see the following:

.\ant -f input.xml -Dinput=部件名 echo
Buildfile: input.xml

echo:
     [echo] The input is: 部件名

BUILD SUCCESSFUL
Total time: 0 seconds


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
Mime
View raw message