ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (IVY-678) Maven version ranges with ( ) are not supported
Date Fri, 04 Jul 2008 07:37:31 GMT

     [ https://issues.apache.org/jira/browse/IVY-678?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Xavier Hanin resolved IVY-678.
------------------------------

    Resolution: Fixed

I've applied your patch and then removed the square brackets in the OPEN_EXC_PATTERN and CLOSE_EXC_PATTERN,
because they are added when these constants are used in OPEN_PATTERN and CLOSE_PATTERN.

Anyway, thanks a lot for your contribution!

> Maven version ranges with ( ) are not supported
> -----------------------------------------------
>
>                 Key: IVY-678
>                 URL: https://issues.apache.org/jira/browse/IVY-678
>             Project: Ivy
>          Issue Type: Bug
>          Components: Maven Compatibility
>            Reporter: Gilles Scokart
>            Assignee: Xavier Hanin
>             Fix For: 2.0-RC1
>
>         Attachments: VersionRangeMatcher.java.patch
>
>
> Maven accept version ranges like this : [3.8,4.0) to mean what ivy mean with [3.8,4.0[
> Same with [ that should be replaced by (

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message