ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Hyerle (JIRA)" <j...@apache.org>
Subject [jira] Closed: (IVY-851) Updated junit test "XmlReportWriterTest.java" unreliable/fails: unmappable character for encoding UTF8
Date Fri, 04 Jul 2008 13:21:45 GMT

     [ https://issues.apache.org/jira/browse/IVY-851?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Hyerle closed IVY-851.
-----------------------------


Checked out new revision, performed "ant clean", then "ant" to re-compile and run tests. 
Javac warning no longer present and unit test passes.

> Updated junit test "XmlReportWriterTest.java" unreliable/fails: unmappable character
for encoding UTF8
> ------------------------------------------------------------------------------------------------------
>
>                 Key: IVY-851
>                 URL: https://issues.apache.org/jira/browse/IVY-851
>             Project: Ivy
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.0-RC1
>         Environment: Fedora 9; i386; Sun jdk1.5.0_15; LANG=en_US.utf8
>            Reporter: Robert Hyerle
>            Priority: Minor
>             Fix For: 2.0-RC1
>
>
> Checked out version 671603, ran "ant" with the following results:
> 1) when building, XmlReportWriterTest.java gets the following warning:
>     [javac] /home/hyerle/usr/ivy/live/ivy/test/java/org/apache/ivy/plugins/report/XmlReportWriterTest.java:74:
warning: unmappable character for encoding UTF8
>     [javac]         String expectedOrg = "organisation=\"sp�cial\"";
>     [javac]
> 2) when running the junit tests, one gets the following failure:
>     [junit] Running org.apache.ivy.plugins.report.XmlReportWriterTest
>     [junit] Tests run: 3, Failures: 1, Errors: 0, Time elapsed: 1,626 sec
>     [junit] Test org.apache.ivy.plugins.report.XmlReportWriterTest FAILED
> This is reported as:
> XML doesn't contain the organisation
> junit.framework.AssertionFailedError: XML doesn't contain the organisation
> at org.apache.ivy.plugins.report.XmlReportWriterTest.testWriteOrigin(XmlReportWriterTest.java:80)
> This is presumably because the mapping of the compiled string "special" (accent on the
'e') without a valid mapping does not match the contents of the test report ("test/repositories/1/special-encoding-root-ivy.xml").
> This test was checked in on 29-may as revision 661275 by gscokart.
> It is unclear to me if the test is broken for certain configurations, or only certain
LANG configurations are supported, or the original bug (IVY-816) was never completely fixed.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message