ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin (JIRA)" <j...@apache.org>
Subject [jira] Updated: (IVY-730) Improve documentation for building Ivy
Date Wed, 25 Jun 2008 10:17:44 GMT

     [ https://issues.apache.org/jira/browse/IVY-730?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Xavier Hanin updated IVY-730:
-----------------------------

         Priority: Minor  (was: Major)
    Fix Version/s:     (was: 2.0)

Postpone since we lack of time to release 2.0, and this is not the highest priority.

> Improve documentation for building Ivy
> --------------------------------------
>
>                 Key: IVY-730
>                 URL: https://issues.apache.org/jira/browse/IVY-730
>             Project: Ivy
>          Issue Type: Improvement
>          Components: Documentation
>            Reporter: Adrian Sandor
>            Priority: Minor
>
> The source distribution currently doesn't contain easily accessible instructions for
building the library or doing various tasks such as obtaining dependencies or integrating
with Eclipse. Specifically:
> - There is a README file, but it only points to install.html, which contains instructions
for installing the *binary* distribution
> - The current download page has a few instructions for building from source (followed
by a broken link to http://ant.apache.org/ivy/downloads/latest/ ), but they are easily overlooked
because people (well, at least I) go there to download stuff, and don't normally scroll down
to see what else it says. Also, the download page is not included in the source distribution.
> - There is a dev.html page, included both on the site and in the source distribution,
but it is not directly referenced. Users must currently find it on their own or be told about
it. Also, that page doesn't mention the jar target for just building the library (but that
also gets done when running the default target, so it's not too bad).
> - Apparently a common problem is having another version of Ivy being loaded by ant when
running the build script. This is not detected, and causes errors such as:
> ivy:settings doesn't support the "override" attribute
> The documentation should advise the users to avoid this situation, and if possible, the
build script should detect when it happens.
> Also see http://www.nabble.com/Re%3A-Possible-Ivy-resolver-bug-td15302716.html#a15370117

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message