ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée (JIRA) <j...@apache.org>
Subject [jira] Resolved: (IVYDE-93) latest build of IvyDE from www.hibnet.org not picking up changes in ivy.xml
Date Fri, 23 May 2008 19:23:55 GMT

     [ https://issues.apache.org/jira/browse/IVYDE-93?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nicolas Lalevée resolved IVYDE-93.
----------------------------------

       Resolution: Fixed
    Fix Version/s: 2.0.0
         Assignee: Nicolas Lalevée

fixed in trunk. Thanks for reporting Mark.

> latest build of IvyDE from www.hibnet.org not picking up changes in ivy.xml
> ---------------------------------------------------------------------------
>
>                 Key: IVYDE-93
>                 URL: https://issues.apache.org/jira/browse/IVYDE-93
>             Project: IvyDE
>          Issue Type: Bug
>    Affects Versions: 2.0.0
>         Environment: Windows XP SP2, Eclipse  3.3.2 M20080221-1800
>            Reporter: Mark Clements
>            Assignee: Nicolas Lalevée
>             Fix For: 2.0.0
>
>
> The latest build (May 16 from www.hibnet.org) appears to have a problem noticing when
ivy.xml has changed. An initial resolve works fine, but modifying ivy.xml and resolving again
has no effect.
> I create a new project TestIvyProject and create an ivy.xml file
> <?xml version="1.0"?>
> <?xml-stylesheet type="text/xsl" 
>                     href="http://hercule/external/ivy/ivy-doc.xsl"?>
> <ivy-module version="1.3" 
>     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>     xsi:noNamespaceSchemaLocation="http://hercule/ivy/ivy.xsd">
>     <info organisation="ofac" module="TestIvyProject" revision="CURRENT"
> />
>     <configurations>
>     <conf name="compile" description="compile-time" transitive="true"
>         visibility="public" />
>     <conf name="run"
>         description="run-time"
>         transitive="false" visibility="public" />
>     </configurations>
>     <dependencies>
>         <dependency org="easymock" name="easymock" rev="2.3" />
>     </dependencies>
>     <conflicts>
>         <manager name="ofac-cm" org="ofac" />
>         <manager name="latest-revision" org="(?!ofac).*" />
>     </conflicts>
> </ivy-module>
> This resolves fine from my repository, and easymock.jar appears in the ivy.xml container.
> Now, if I add
>   <dependency org="apache" name="commons-lang" rev="latest.release" />
> To <dependencies> and resolve again, the new dependency is not resolved, and is
not even mentioned in the ivy log. If I rollback the IvyDE plugin to the 3 April build, the
behaviour is as expected.
> regards - Mark

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message