ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hi...@apache.org
Subject svn commit: r659970 - in /ant/ivy/ivyde/trunk/doc: build.html console.html
Date Sun, 25 May 2008 11:54:11 GMT
Author: hibou
Date: Sun May 25 04:54:11 2008
New Revision: 659970

URL: http://svn.apache.org/viewvc?rev=659970&view=rev
Log:
- Fix some links
- add additionnal info about color and the IvyConsole
- Add notices about some build issues

Modified:
    ant/ivy/ivyde/trunk/doc/build.html
    ant/ivy/ivyde/trunk/doc/console.html

Modified: ant/ivy/ivyde/trunk/doc/build.html
URL: http://svn.apache.org/viewvc/ant/ivy/ivyde/trunk/doc/build.html?rev=659970&r1=659969&r2=659970&view=diff
==============================================================================
--- ant/ivy/ivyde/trunk/doc/build.html (original)
+++ ant/ivy/ivyde/trunk/doc/build.html Sun May 25 04:54:11 2008
@@ -31,7 +31,7 @@
 
 <h2>Eclipse installation</h2>
 
-You need first an Eclipse install. We will refer to the eclipse installation path in the
documentation as $ECLIPSE_HOME. In that $ECLIPSE_HOME folder you should have the plugins and
features folders. The current build have been successfully tested with:
+You need first an Eclipse install which contains the PDE plugins (by default included in
the "SDK" and "Classic" versions). We will refer to the eclipse installation path in the documentation
as $ECLIPSE_HOME. In that $ECLIPSE_HOME folder you should have the plugins and features folders.
The current build have been successfully tested with:
 <ul>
 <li>Eclipse 3.2 under Linux</li>
 <li>Eclipse 3.3.1 under Linux and Windows</li>
@@ -43,6 +43,7 @@
 The IvyDE plugins depends on the Ivy 2 OSGi bundle. So the Ivy bundle have to be installed
in the Eclipse installation before starting the build.
 
 You can get an officially released version of Ivy. Go to the <a href="http://ant.apache.org/ivy/download.html">Ivy
download page</a> and get the binary distribution. You will find in the zip the jar
ivy-2.X.Y-Z.jar.
+Note: due to <a href="https://issues.apache.org/jira/browse/IVY-802">a bug in the build
script of Ivy</a>, the OSGi version of Ivy will be "0.0.0". On the other hand it doesn't
prevent IvyDE to runs correctly.
 
 You can also build it from the sources (from <a href="https://svn.apache.org/repos/asf/ant/ivy/core/trunk/">subversion</a>
or from the <a href="http://ant.apache.org/ivy/download.html">releases</a>). In
the build/artifact folder you should then find the bundle org.apache.ivy_2.X.Y-Z.jar.
 
@@ -57,7 +58,7 @@
 And run the build:
 <code>ant build -DbaseLocation=$ECLIPSE_HOME</code>
 
-The baseLocation property is mandatory: it defines the path of you Eclipse install you want
to build with.
+The baseLocation property is mandatory: it defines the path of your Eclipse install you want
to build with.
 
 Note that it is not recommended to have your Eclipse started when you build IvyDE. The build
clean the Eclipse cache of installed plugins, so your running Eclipse might be confused.
 

Modified: ant/ivy/ivyde/trunk/doc/console.html
URL: http://svn.apache.org/viewvc/ant/ivy/ivyde/trunk/doc/console.html?rev=659970&r1=659969&r2=659970&view=diff
==============================================================================
--- ant/ivy/ivyde/trunk/doc/console.html (original)
+++ ant/ivy/ivyde/trunk/doc/console.html Sun May 25 04:54:11 2008
@@ -29,6 +29,15 @@
 The Ivy Console can be accessed within your eclipse Console view, selecting the "Ivy Console"
item.<br/>
 <br/>
 <center><img src="images/ivy_console.jpg"></center><br/>
+<br/>
+The colors in the console correspond to the different log levels. Here is the default mapping:
+<ul>
+<li>Debug: light blue</li>
+<li>Verbose: green</li>
+<li>Info: black</li>
+<li>Warn: orange</li>
+<li>Error: red</li>
+</ul>
 </textarea>
 <script type="text/javascript">xooki.postProcess();</script>
 </body>



Mime
View raw message