ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée (JIRA) <j...@apache.org>
Subject [jira] Commented: (IVYDE-34) internal error when doing resolve
Date Tue, 01 Apr 2008 13:15:07 GMT

    [ https://issues.apache.org/jira/browse/IVYDE-34?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12584130#action_12584130
] 

Nicolas Lalevée commented on IVYDE-34:
--------------------------------------

As far as I understand, there is no interesting stacktrace because the source of the error
is an exception that have been raise in the started thread in the ResolveJob. So the thread
dies with its exception. But that exception should be logged in the System.err. So if you
started Eclipse from a console, you should be able to see the interesting stack trace (the
stack trace might be different of each of us, so it should be another jira issue).

Then there is a bug in the resolve job that doesn't detected this unexpected behaviour that
make the NPE in the Eclipse worker.


> internal error when doing resolve
> ---------------------------------
>
>                 Key: IVYDE-34
>                 URL: https://issues.apache.org/jira/browse/IVYDE-34
>             Project: IvyDE
>          Issue Type: Bug
>          Components: classpath container
>    Affects Versions: 1.1.0
>            Reporter: Maarten Coene
>            Assignee: Xavier Hanin
>
> I receive an error with Eclipse 3.2.0. When I do a resolve, I receive an internal error!
(no popup-dialog from Ivy and no error on IvyConsole).
> The following appears in my Eclipse log:
> !ENTRY org.eclipse.core.jobs 4 2 2006-10-10 12:20: 34.202
> !MESSAGE An internal error occurred during: "Resolve salloca/ant/ivy.xml dependencies".
> !STACK 0
> java.lang.NullPointerException
>     at org.eclipse.core.internal.jobs.Worker.run(Worker.java:73)
> The above error occurs everytime I do a resolve. No further stacktrace is available :-(
> Also, if I use Eclipse 3.2.1 the resolves works without a problem...
> If I do a resolve in Ant of the same Ivy file (and same config file and same configurations),
I don't get an error....
> regards,
> Maarten

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message