ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject DO NOT REPLY [Bug 35060] ant 1.6.4 does not seem to use ~/.ant/lib anymore
Date Fri, 18 Apr 2008 22:54:28 GMT

Trevin Beattie <> changed:

           What    |Removed                     |Added
                 CC|                            |

--- Comment #4 from Trevin Beattie <>  2008-04-18 15:54:27 PST ---

Why does ClasspathUtils.getUniqueClassLoaderForPath no longer set the new class
loader's classpath to the system class path when no explicit path is provided?

I'm having this same problem with ivy.  I tried copying ant.jar and
ant-launcher.jar to /usr/share/java/ant/ as Kaj suggested, but in my case I
still got the error "Could not create task or type of type:

I loaded up ant in Eclipse's debugger and tried to trace through it.  All of
the jars in ~/.ant/lib/ are added to the java.class.path system property as
well as the thread's context class loader, but when ant goes to load the
resource "org/apache/ivy/ant/antlib.xml", it's not using that URLClassLoader;
it's using a new AntClassLoader2 instead.

Configure bugmail:
------- You are receiving this mail because: -------
You are the assignee for the bug.

View raw message