ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Xavier Hanin (JIRA)" <j...@apache.org>
Subject [jira] Updated: (IVY-297) Change allownomd and skipbuildwithoutivy into a more semantically correct name
Date Thu, 03 Apr 2008 11:24:24 GMT

     [ https://issues.apache.org/jira/browse/IVY-297?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Xavier Hanin updated IVY-297:
-----------------------------

    Summary: Change allownomd and skipbuildwithoutivy into a more semantically correct name
 (was: Please change allownomd into a more semantically correct name)

> Change allownomd and skipbuildwithoutivy into a more semantically correct name
> ------------------------------------------------------------------------------
>
>                 Key: IVY-297
>                 URL: https://issues.apache.org/jira/browse/IVY-297
>             Project: Ivy
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 1.4-RC1
>            Reporter: Stephane Bailliez
>            Assignee: Xavier Hanin
>             Fix For: 2.0
>
>
> Please please please please.
> Try to be consistent and avoiding funny names like 'allownomd'. Any sane person reading
that will wonder what this is.
> This is annoying as you have in buildlist the attribute "skipbuildwithoutivy" where ivy
is describing the 'module descriptor', so you have to make a choice of calling it either ivy
either descriptor, but md is cryptic at best.
> why not something like descriptor="required|optional" or ivy="required|optional" ?
> xml is not limited to boolean values

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message